Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002091TestLinkRequirement Managementpublic2009-02-11 05:182009-02-13 19:01
Reportermkbutler 
Assigned Toschlundus 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version1.8 RC 3 
Fixed in Version1.8 RC 4 
Summary0002091: Requirement Specs not printing correctly
DescriptionIt's because of a missing HTML header function used in requirements.inc.php
In the file "lib\functions\requirements.inc.php" there is a call to printHeader($title,$base_href)

I think it's supposed to be calling "buildHTMLHeader($title,'',$base_href)" instead.
Additional InformationIf you go to a requirement spec and print it you'll get an error.
Fatal error: Call to undefined function printHeader() in E:\Websites\testlink\lib\functions\requirements.inc.php on line 64

Commenting out that line gets it to work.
Replacing it with "$output = buildHTMLHeader($title,'',$base_href);" I think gets it working the way it's supposed to.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 2.0.0.20
PHP Version5.5?
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0001920closedschlundus Fatal error while printing requirement 

-  Notes
(0005396)
fman (administrator)
2009-02-11 18:34

Please update to RC 4 and retest
(0005417)
fman (administrator)
2009-02-12 02:26

I've checked yesterday night that on new code and in releases RC4 there are no calls to printHeader(), that's why I've asked user to retest.

- Issue History
Date Modified Username Field Change
2009-02-11 05:18 mkbutler New Issue
2009-02-11 05:18 mkbutler Browser => Firefox 2.0.0.20
2009-02-11 05:18 mkbutler PHP Version => 5.5?
2009-02-11 18:34 fman Note Added: 0005396
2009-02-11 18:34 fman Assigned To => fman
2009-02-11 18:34 fman Status new => feedback
2009-02-12 01:44 schlundus Status feedback => assigned
2009-02-12 01:44 schlundus Assigned To fman => schlundus
2009-02-12 02:26 fman Note Added: 0005417
2009-02-12 03:11 schlundus Relationship added duplicate of 0001920
2009-02-12 03:11 schlundus Duplicate ID 0 => 1920
2009-02-12 03:11 schlundus Status assigned => resolved
2009-02-12 03:11 schlundus Fixed in Version => 1.8 RC 4
2009-02-12 03:11 schlundus Resolution open => duplicate
2009-02-13 19:01 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker