Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002090TestLinkUser Interface Generalpublic2009-02-11 02:052009-03-17 15:40
Reporterazl 
Assigned Toazl 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 4 
Fixed in Version1.8 RC 5 
Summary0002090: EXTJS tree doesn't show counter colors during execution
DescriptionOn line 1559 in /lib/functions/treeMenu.inc.php the create_counters_info function isn't properly setting the colors.

Change the second parameter to $useColors. This fixes the tree so that it correctly shows colors.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0005377)
azl (administrator)
2009-02-11 02:07

Fix committed to CVS.
(0005397)
fman (administrator)
2009-02-11 18:42

Subject is wrong, because colors not displayed regards only COUNTERS, as was explained in description.

IMHO using colors on counter decrease readability,
I will open a new issue to add a new config parameter
(0005401)
mhavlat (reporter)
2009-02-11 21:58

Francisco,
there is already config:
// ENABLED -> test cases and test case counters will be coloured according to test case status
$tlCfg->exec_cfg->enable_tree_colouring = ENABLED;

I agree with worse readability - but not with solution. We should use different colours
(0005405)
fman (administrator)
2009-02-11 22:21

I want to have possibility to manage colors on counters, in a separated way that coloring of tree leaves (test cases), that why I would like to add new config parameter.
(0005408)
azl (administrator)
2009-02-11 23:33

FYI I changed colors on my install so that they are more readable IMO.

.passed {
        color: white;
        background: #66FF66; /* light green */
}

.failed {
        color: white;
        background: #FF1583; /* lighter red */
}

.blocked {
        color: white;
        background: #6699FF; /* light blue */
}

.not_run {
        color: white;
        background: #BDAC71; /* light brown */
}

This could be another possible solution.

Having a separate config parameter such as enable_tree_counter_coloring would also be fine with me.

Whatever we do, we should make sure it applies to the other tree types too since I implemented this the same way it is done for the other trees.
(0005409)
mhavlat (reporter)
2009-02-12 00:01

Exactly. CSS is responsible for colours.
Not configuration!
(0005411)
fman (administrator)
2009-02-12 00:20

Configuration is responsible of saying if user wants to use or not colouring, and I've said only this, nothing more / nothing else.
(0005412)
azl (administrator)
2009-02-12 00:29

Adding a separate config paramater for the counter colors seems reasonable. However, we should make it clear what the distinction between tree colors and counter colors is. Even I wasn't clear there was an intended distinction because ALL the other trees have colored counters when tree coloring is enabled.

Regardless of what we choose to do, we must be consistent through all tree types.

I was only pointing out color changes I made because you said the current colors decrease readability. IMO the colors I have suggested improve the readability significantly.

- Issue History
Date Modified Username Field Change
2009-02-11 02:05 azl New Issue
2009-02-11 02:06 azl Status new => assigned
2009-02-11 02:06 azl Assigned To => azl
2009-02-11 02:07 azl Status assigned => resolved
2009-02-11 02:07 azl Fixed in Version => next DEV - 1.8 RC 5
2009-02-11 02:07 azl Resolution open => fixed
2009-02-11 02:07 azl Note Added: 0005377
2009-02-11 18:42 fman Note Added: 0005397
2009-02-11 21:58 mhavlat Note Added: 0005401
2009-02-11 22:21 fman Note Added: 0005405
2009-02-11 23:33 azl Note Added: 0005408
2009-02-11 23:34 azl Summary EXTJS tree doesn't show colors during execution => EXTJS tree doesn't show counter colors during execution
2009-02-12 00:01 mhavlat Note Added: 0005409
2009-02-12 00:20 fman Note Added: 0005411
2009-02-12 00:29 azl Note Added: 0005412
2009-03-17 15:40 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker