Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002065TestLinkUsers and Rightspublic2009-02-05 14:162009-02-13 19:01
Reporterunixadmin007 
Assigned Toschlundus 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 3 
Fixed in Version1.8 RC 4 
Summary0002065: Test Project Level permissions display issue
Description>> create a user A with Lead permission at global level.
>> on project "Test" this user has Lead permission by default.
>> Now if as admin i change user A to no rights on Project "Test" and click on save it is saving as <inherited>-Lead

Expected==>> It should save as no-rights

Actual==>> It is saving as <inherited>-Lead
Additional Information>> However if User A is logged in, he does not see Prject "Test",
it is confusing to Admin that which users have no access on a particular project.
i can say it is display issue only.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 3.0.5
PHP Version5.2.6
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0001903closedschlundus Can't assign one user to one project with <no rights> 

-  Notes
(0005258)
fman (administrator)
2009-02-05 15:25

1. Please update to RC 3, we do not test on early versions, because issue may be has fixed on newer versions.

2.
>> it is confusing to Admin that which users have no access on a particular >>project.
Please explain better, is not clear
(0005260)
unixadmin007 (reporter)
2009-02-05 15:47

checked with RC3 as well.. same issue

I mean if I am global admin, i am going to Assign Test Project Role link and setting a Lead user (at global level) privilege to no rights in a particular project, after updating it shows <inherited> Lead, and if this user is login to TL this particular project is not coming for him which is expected but for global admin why it should say <inherited> Lead

Expected==>> Permission should be no right on the particular project
(0005261)
fman (administrator)
2009-02-05 15:53

With this additional information, now we will be able to work.
Please always give a good level of details and steps to reproduce.
Not too much info, no only few words, just a good balance, as is explained in all documentation you can find about how to report issues in an efficient way
(0005282)
schlundus (reporter)
2009-02-06 01:47

@unixadmin007
Please check the issue 0001903 if this is your problem?
(0005300)
unixadmin007 (reporter)
2009-02-07 02:16

here is the problem
I have a user with global level "No Permission"
at a Project level he/she is lead, but if he clicks on "Assign Test Case execution" on homepage and choose a testcase from list, he does not see his name on Bulk user assignment list, while he can see others name on drop down menu.
(0005301)
schlundus (reporter)
2009-02-07 03:32

Äh?
Can you tell us, what's the relationship between the bug description
and the actual problem in your comment?
I can only hope that your testers write better bug reports than you.
This is a good example of wasting other people times!
didn't you know that there is a relationship between a "Good bug report" and "Getting the bug fixed"?
(0005302)
unixadmin007 (reporter)
2009-02-07 03:35

issue 0001903 solved the previous problem as mentioned by you, this is the another problem
(0005303)
schlundus (reporter)
2009-02-07 03:35

Bug reproduced
(0005304)
schlundus (reporter)
2009-02-07 03:51

If this is a new kind of problem, why isn't there a new bug?
Don't mix different bugs in one single issue! (simple rule)
(0005305)
unixadmin007 (reporter)
2009-02-07 03:53

because I saw this problem just after changing the code.
(0005306)
schlundus (reporter)
2009-02-07 03:54
edited on: 2009-02-07 17:43

Wrong function arguments caused the bug
Fixed and checked in
within tc_exec_assignment.php

search for
$users = tlUser::getAll($dbHandler,null,"id",null,tlUser::TLOBJ_O_GET_DETAIL_MINIMUM);
and change it to

$users = tlUser::getAll($dbHandler,null,"id",null);


- Issue History
Date Modified Username Field Change
2009-02-05 14:16 unixadmin007 New Issue
2009-02-05 14:16 unixadmin007 Browser => Firefox 3.0.5
2009-02-05 14:16 unixadmin007 PHP Version => 5.2.6
2009-02-05 15:25 fman Note Added: 0005258
2009-02-05 15:25 fman Status new => feedback
2009-02-05 15:47 unixadmin007 Note Added: 0005260
2009-02-05 15:51 fman Product Version 1.8 RC 1 => 1.8 RC 3
2009-02-05 15:53 fman Note Added: 0005261
2009-02-06 01:26 schlundus Status feedback => assigned
2009-02-06 01:26 schlundus Assigned To => schlundus
2009-02-06 01:46 schlundus Relationship added duplicate of 0001903
2009-02-06 01:47 schlundus Note Added: 0005282
2009-02-07 02:16 unixadmin007 Note Added: 0005300
2009-02-07 03:32 schlundus Note Added: 0005301
2009-02-07 03:35 unixadmin007 Note Added: 0005302
2009-02-07 03:35 schlundus Note Added: 0005303
2009-02-07 03:35 schlundus Status assigned => confirmed
2009-02-07 03:51 schlundus Note Added: 0005304
2009-02-07 03:53 unixadmin007 Note Added: 0005305
2009-02-07 03:54 schlundus Status confirmed => resolved
2009-02-07 03:54 schlundus Fixed in Version => 1.8 RC 4
2009-02-07 03:54 schlundus Resolution open => fixed
2009-02-07 03:54 schlundus Note Added: 0005306
2009-02-07 17:20 schlundus Note Edited: 0005306
2009-02-07 17:43 schlundus Note Edited: 0005306
2009-02-13 19:01 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker