Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002033TestLinkTest Specificationpublic2009-01-29 14:242009-04-05 00:42
Reporterunixadmin007 
Assigned Toschlundus 
PrioritynormalSeveritytweakReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version1.8.0 
Summary0002033: Search Test cases with testcase id is not working
Description>> go to home page
>> Click on Search Test cases
>> In test case id give internal id
>> Test case ID box is limited to 8 alphanumeric character only.

Expected ==>> It should display result
Actual==>> it is giving a message Your search delivered no results!

I am aware in V1.8 we need to provide prefix while searching, but box limitation is just 8 characters.
Additional InformationWe migrated from 1.7 to 1.8 and Updated external id's with internal id in order to display correct test case id.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 3.0.5
PHP Version5.2.6
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0002151closedfman Searching testcases : Search with Testcase ID does not work 
related to 0002165closedfman Search Test Case - Make user life easier preloading test case prefix on search input 

-  Notes
(0005150)
mhavlat (reporter)
2009-01-29 18:11

I fixed the problem (1.8 RC4).
However, another action required for usability. User should setup a number only - not prefix. Prefix should be showed before input element.
The case happens also with TestPlan navigator.
(0005165)
unixadmin007 (reporter)
2009-01-30 01:27

is it possible to increase box limit for more than 8 chars, please point me to code
(0005219)
schlundus (reporter)
2009-02-04 03:12

I absolutly agree, because the prefix is always the same for the whole project, so need to enter it explicitly! => 1.9
(0005220)
unixadmin007 (reporter)
2009-02-04 03:14

is it possible to increase box limit for more than 8 chars in existing 1.8 RC1 version, if yes please point me to code
(0005221)
schlundus (reporter)
2009-02-04 03:28

check navbar.tpl for something like 'searchTC' or wait until the next version is released
(0005223)
unixadmin007 (reporter)
2009-02-04 04:31

i did not get size limit parameter in this file, it just says about font size
(0005307)
schlundus (reporter)
2009-02-07 03:55

Add it?
(0006202)
sdalia (reporter)
2009-04-04 01:44

I'm having same issue with Search. After I update external_id with internal id search works but when you are creating new test case it goes back to 1,2,3 so that can be part of the migrated test cases
(0006208)
fman (administrator)
2009-04-04 23:09

@sdalia:
an script was added on directory
\third_party\user_contribution\
of your installation that was the job to align ids

Anyway on 1.8.0 search works as expected
(0006209)
fman (administrator)
2009-04-04 23:10

test case prefix was added on search box to make clear what id must be used

- Issue History
Date Modified Username Field Change
2009-01-29 14:24 unixadmin007 New Issue
2009-01-29 14:24 unixadmin007 Browser => Firefox 3.0.5
2009-01-29 14:24 unixadmin007 PHP Version => 5.2.6
2009-01-29 18:11 mhavlat Note Added: 0005150
2009-01-29 18:11 mhavlat Severity major => tweak
2009-01-29 18:11 mhavlat Category General => Test Specification
2009-01-29 18:11 mhavlat Description Updated
2009-01-30 01:27 unixadmin007 Note Added: 0005165
2009-01-30 03:14 schlundus Status new => assigned
2009-01-30 03:14 schlundus Assigned To => schlundus
2009-02-04 03:11 schlundus Status assigned => acknowledged
2009-02-04 03:12 schlundus Note Added: 0005219
2009-02-04 03:14 unixadmin007 Note Added: 0005220
2009-02-04 03:28 schlundus Note Added: 0005221
2009-02-04 04:31 unixadmin007 Note Added: 0005223
2009-02-07 03:55 schlundus Note Added: 0005307
2009-02-28 00:07 fman Relationship added duplicate of 0002151
2009-03-02 17:44 fman Relationship added related to 0002165
2009-04-04 01:44 sdalia Note Added: 0006202
2009-04-04 23:09 fman Note Added: 0006208
2009-04-04 23:10 fman Status acknowledged => resolved
2009-04-04 23:10 fman Fixed in Version => 1.8.0
2009-04-04 23:10 fman Resolution open => fixed
2009-04-04 23:10 fman Note Added: 0006209
2009-04-05 00:42 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker