Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002020TestLinkInstallerpublic2009-01-26 20:122009-02-06 06:49
Reporterrinmar 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 3 
Fixed in Version1.8 RC 4 
Summary0002020: migration 1.7.3 -> 1.8 - testcase id porblems- Utility to align external ID with internal ID after migration
DescriptionTest Migration from 1.7.3 with 1.8 RC4 26.01.09 Snapshot
(because of fix in php check)

Testcase ID in 1.7.3 was 3575
Testcase ID in 1.8 after migration is Prefix-1495
Additional InformationOur testautom. is based on testcase id. Prefix is OK.

We want to move to new 1.8 Version, but testcase id has to be the same
as in 1.7.3 after migration
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 7
PHP Version5.2.8
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon user_contribution.zip [^] (1,078 bytes) 2009-01-27 03:54

- Relationships

-  Notes
(0005112)
mhavlat (reporter)
2009-01-26 22:42
edited on: 2009-01-26 22:44

Verify that install/sql/alter_tables/1.8/<db type>/DB.1.2/db_schema_update.sql was executed over your database.
It was not executed in my very last attempt. (For example table testprojects have had about three new fields.)
Any your finding will speed up fixing the problem. Thanks.

Did you see any SQL error during migration?
Which DB type are you using?

(0005113)
rinmar (reporter)
2009-01-26 23:07
edited on: 2009-01-26 23:10

5.0.51b
no error in logs, i ran standard migration from url:
install/migration/migrate_17/migrate_17_to_18.php

and sql script. but testcase id is still wrong.

I think viewed is now the external id, but i tought that migration
will set the external id from current testcase id?

(0005114)
rinmar (reporter)
2009-01-26 23:07

Connecting to Testlink 1.7.2 (source) database. - testlink - OK!
Due to total test cases quantity Migration process will take at least 15 min

(Memory Usage: 5427576 | Peak: 5431760)

Migration process STARTED :: 16:06:23



Please be patient this may take some time!



--------------------------------------------------------------------------------


 Requirement Specification: click to show 16:06:23
Number of Requirements Specifications (SRS): 2
 Requirements: click to show 16:06:23

Number of requirements: 5
Total number of Test Projects to process: 1
Working on Test Project (1/1) : MoVe4
(Memory Usage: 5692952 | Peak: 5726848)

Test Cases to process: 2065

Test Cases Processed: 100 - 16:06:25
Test Cases Processed: 200 - 16:06:27
Test Cases Processed: 300 - 16:06:29
Test Cases Processed: 400 - 16:06:32
Test Cases Processed: 500 - 16:06:34
Test Cases Processed: 600 - 16:06:37
Test Cases Processed: 700 - 16:06:39
Test Cases Processed: 800 - 16:06:42
Test Cases Processed: 900 - 16:06:44
Test Cases Processed: 1000 - 16:06:47
Test Cases Processed: 1100 - 16:06:49
Test Cases Processed: 1200 - 16:06:52
Test Cases Processed: 1300 - 16:06:55
Test Cases Processed: 1400 - 16:06:58
Test Cases Processed: 1500 - 16:07:01
Test Cases Processed: 1600 - 16:07:04
Test Cases Processed: 1700 - 16:07:07
Test Cases Processed: 1800 - 16:07:10
Test Cases Processed: 1900 - 16:07:13
Test Cases Processed: 2000 - 16:07:16
ALL Test Cases Processed: 2065 - 16:07:18


 
Migration process finished! :: 16:07:18
Click Here to login
(0005116)
fman (administrator)
2009-01-26 23:48

>>Testcase ID in 1.7.3 was 3575
>>Testcase ID in 1.8 after migration is Prefix-1495

INTERNAL TEST CASE ID ARE PRESERVED during migration,
what you are seeing now is EXTERNAL TEST ID => do not worry.

on 1.8 Internal Test Case ID is NOT SHOWED ANYMORE
(0005118)
rinmar (reporter)
2009-01-27 00:28

so the question is:
how could i use the orginal tc id as external id in migration process?

in the current migration it creates (based on ?) a
standard external id start from 1.
(0005119)
fman (administrator)
2009-01-27 00:31

>>> how could i use the orginal tc id as external id in migration process?
After migration, you can write some sql to update external id with internal id, but YOU MUST USE a prefix because is MANDATORY.

Then you can update test case counter on testproject table, to start new test cases from right id.
(0005123)
fman (administrator)
2009-01-27 03:55

here a solution (may be). This will update external id with internal id for all testprojects.
unpack attached file under third_party, and try it

please let us know
(0005132)
rinmar (reporter)
2009-01-27 17:30

works well, thank you very much! could be set to resolved

- Issue History
Date Modified Username Field Change
2009-01-26 20:12 rinmar New Issue
2009-01-26 20:12 rinmar Browser => IE 7
2009-01-26 20:12 rinmar PHP Version => 5.2.8
2009-01-26 22:42 mhavlat Note Added: 0005112
2009-01-26 22:42 mhavlat Status new => feedback
2009-01-26 22:43 mhavlat Note Edited: 0005112
2009-01-26 22:44 mhavlat Priority normal => urgent
2009-01-26 22:44 mhavlat Severity minor => major
2009-01-26 22:44 mhavlat Note Edited: 0005112
2009-01-26 23:07 rinmar Note Added: 0005113
2009-01-26 23:07 rinmar Note Added: 0005114
2009-01-26 23:10 rinmar Note Edited: 0005113
2009-01-26 23:10 rinmar Note Edited: 0005113
2009-01-26 23:48 fman Note Added: 0005116
2009-01-27 00:28 rinmar Note Added: 0005118
2009-01-27 00:31 fman Note Added: 0005119
2009-01-27 03:54 fman File Added: user_contribution.zip
2009-01-27 03:55 fman Note Added: 0005123
2009-01-27 17:30 rinmar Note Added: 0005132
2009-01-27 18:39 fman Summary testcase_id migration 1.7.3 -> 1.8 => migration 1.7.3 -> 1.8 - testcase id porblems- Utility to align external ID with internal ID after migration
2009-01-27 18:40 fman Status feedback => resolved
2009-01-27 18:40 fman Fixed in Version => next DEV - 1.8 RC 4
2009-01-27 18:40 fman Resolution open => fixed
2009-01-27 18:40 fman Assigned To => fman
2009-02-06 06:49 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker