Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002018TestLinkInstallerpublic2009-01-26 00:352009-02-06 06:49
Reportermhavlat 
Assigned Tofman 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 3 
Fixed in Version1.8 RC 4 
Summary0002018: Migration 1.7 to 1.8 - SQL errors
DescriptionI run migration 1.7.4 to 1.8 RC3 with the next SQL errors. I have not time to get in yet.


ERROR ON exec_query() - database.class.php
1054 - Unknown column 'prefix' in 'field list' - UPDATE testprojects SET prefix='CPS (ID=4837)', tc_counter=0 WHERE id=4837
...
THE MESSAGE :: SQL [2745] executed [took 0.0002 secs][all took 3.3044 secs]: UPDATE testprojects SET prefix='CPS (ID=4837)', tc_counter=0 WHERE id=4837 Query failed: errorcode[1054] errormsg:Unknown column 'prefix' in 'field list'
ERROR ON exec_query() - database.class.php
1054 - Unknown column 'prefix' in 'field list' - UPDATE testprojects SET prefix='GBG (ID=5061)', tc_counter=0 WHERE id=5061
...
ERROR ON exec_query() - database.class.php
1054 - Unknown column 'tc_external_id' in 'field list' - UPDATE tcversions SET tc_external_id=1 WHERE id IN (SELECT id FROM nodes_hierarchy WHERE parent_id=2938)
...
ERROR ON exec_query() - database.class.php
1054 - Unknown column 'tc_counter' in 'field list' - UPDATE testprojects SET tc_counter=939 WHERE id=4781
...
THE MESSAGE :: SQL [5020] executed [took 0.0001 secs][all took 4.6903000000004 secs]: UPDATE testprojects SET tc_counter=939 WHERE id=4781 Query failed: errorcode[1054] errormsg:Unknown column 'tc_counter' in 'field list'
ERROR ON exec_query() - database.class.php
1054 - Unknown column 'tcversion_number' in 'field list' - update executions E,tcversions TCV set tcversion_number=TCV.version where TCV.id = E.tcversion_id

THE MESSAGE :: SQL [5021] executed [took 0.0002 secs][all took 4.6906000000004 secs]: update executions E,tcversions TCV set tcversion_number=TCV.version where TCV.id = E.tcversion_id Query failed: errorcode[1054] errormsg:Unknown column 'tcversion_number' in 'field list'
Migration process finished! :: 18:40:51
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0002016closedmhavlat Migration from 1.7.3 to 1.8 

-  Notes
(0005109)
fman (administrator)
2009-01-26 02:58

see sql scripts in alter folder under DB1.2 this can help you,
let me know if you want help
(0005126)
mhavlat (reporter)
2009-01-27 06:32

I updated and fixed create_data sql scripts regarding roles under this task. (byproduct of this issue).

Could anybody confirm if my case happens everytime:
(migration 1.7->1.8) does not run alter_tables SQL script

ENV: Centos 5.2 + mysql-5.0.45 + php-5.2.6
(0005130)
fman (administrator)
2009-01-27 15:26

Problem is this:
due to may be misleading instructions, while refactoring installer, dev team blocked via Javascript ability to run UPGRADE database.
(0005133)
mhavlat (reporter)
2009-01-27 20:27

I expect:
1) Migration could be stopped if wrong DB version is used - it doesn't happen.
2) Migration will run alter tables automatically. Is there a reason why we should not add "alter_table" step into migration procedure?
(0005134)
fman (administrator)
2009-01-27 21:11

Migration process can be improved but:
- Has been the same from first release of 1.8 (at least 8 months)
- Has been used without problems by final users.

>> 1) Migration could be stopped if wrong DB version is used - it doesn't happen.
OK, I will add this control

>> 2) Migration will run alter tables automatically. Is there a reason why we should not add "alter_table" step into migration procedure?

I will check (for 1.9).
I have choosed this mode of operation because was the easier way to reach desired results, and not requires a significat user effort.
(0005135)
mhavlat (reporter)
2009-01-27 22:57

Thank you.

- Issue History
Date Modified Username Field Change
2009-01-26 00:35 mhavlat New Issue
2009-01-26 00:53 mhavlat Relationship added related to 0002016
2009-01-26 02:58 fman Note Added: 0005109
2009-01-27 06:32 mhavlat Note Added: 0005126
2009-01-27 15:26 fman Note Added: 0005130
2009-01-27 15:27 fman Status new => resolved
2009-01-27 15:27 fman Fixed in Version => next DEV - 1.8 RC 4
2009-01-27 15:27 fman Resolution open => fixed
2009-01-27 15:27 fman Assigned To => fman
2009-01-27 20:27 mhavlat Note Added: 0005133
2009-01-27 21:11 fman Note Added: 0005134
2009-01-27 22:57 mhavlat Note Added: 0005135
2009-02-06 06:49 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker