Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001992TestLinkNew Featurepublic2009-01-17 09:372009-01-20 05:19
Reportermirosvad 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 2 
Fixed in Version1.8 RC 3 
Summary0001992: Contribution - XLS import - Convert new line characters from XLS to HTML

in order to let testlink display them correctly
DescriptionCurrent version of tcimport.php import xls with binary new line characters. That results in testlink inability to display the new line in summary, steps and expected results textarea correctly (because testlink does it in HTML

notation as seen in xml export).

I've add the function nl2p which enclose every line in

tags and call it in order to convert all summary, steps and expected results imported content.

Changes are available and marked (lines which starts with /* MS */ within source file in attachment (including the fix for bug id 1991)
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 3
PHP Version5.2
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon tcImport.zip [^] (4,985 bytes) 2009-01-17 09:37

- Relationships
related to 0001519closedtoshi Excel Importing Misses Multi-byte Charactors 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2009-01-17 09:37 mirosvad New Issue
2009-01-17 09:37 mirosvad File Added: tcImport.zip
2009-01-17 09:37 mirosvad Browser => Firefox 3
2009-01-17 09:37 mirosvad PHP Version => 5.2
2009-01-17 16:32 fman Status new => assigned
2009-01-17 16:32 fman Assigned To => fman
2009-01-18 01:46 fman Status assigned => resolved
2009-01-18 01:46 fman Fixed in Version => next development 1.8 RC3
2009-01-18 01:46 fman Resolution open => fixed
2009-01-20 05:19 mhavlat Status resolved => closed
2009-04-02 08:06 toshi Relationship added child of 0001519
2009-04-02 08:06 toshi Relationship deleted child of 0001519
2009-04-02 08:06 toshi Relationship added related to 0001519



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker