Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001973TestLinkTest Executepublic2009-01-09 19:372011-03-18 19:09
Reportertina 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.4 
Fixed in Version1.8.5 (bug fixing) 
Summary0001973: It spent too much time to load the test suite which with plenty of test cases
Description1.There are many test cases under one test suite.
2.Assign this test suite to one tester
3.The tester enters the execution page
4.Click the suite
5.Execute one test case and press save button
Additional InformationIt spent much time to load the page in step 4 and step 5
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0004984)
fman (administrator)
2009-01-09 19:41
edited on: 2009-01-09 19:42

migrate to 1.8 RC2, that have performance improvements.
An please detail test qty (plenty is useless)

(0004985)
mhavlat (reporter)
2009-01-09 22:47

Tina, Could you try 1.8 version performance for your case?
There should be improvements, that are you looking for. You can also see other performance related issues on this tracker.
We do not plan backport these improvements to 1.7 branch.
(0004995)
tina (reporter)
2009-01-13 17:34

Hi,it just 149 items.
I will try it in 1.8 version.
Thanks a lot.
(0005000)
Laurent (reporter)
2009-01-14 14:58

We load 7000+ test cases over a very slow link to our team in China. 1.8 offers an INCREDIBLE performance improvement over 1.7.4 (from 70 seconds to about 3).

I also suggested that you enable compression on the Apache side (if you use Apache). This helps quite a bit.

1.8 RC2 reporting has some problems but nothing you can't live with. We have been using it (RC1 and now RC2) in a production environment since November.
(0014038)
fman (administrator)
2011-03-18 19:09

solved on old releases - mantis clean up

- Issue History
Date Modified Username Field Change
2009-01-09 19:37 tina New Issue
2009-01-09 19:37 tina Browser => IE7
2009-01-09 19:41 fman Note Added: 0004984
2009-01-09 19:42 fman Note Edited: 0004984
2009-01-09 22:47 mhavlat Note Added: 0004985
2009-01-09 22:47 mhavlat Status new => feedback
2009-01-13 17:34 tina Note Added: 0004995
2009-01-14 14:58 Laurent Note Added: 0005000
2010-10-31 17:51 fman Status feedback => resolved
2010-10-31 17:51 fman Fixed in Version => 1.8.5 (bug fixing)
2010-10-31 17:51 fman Resolution open => fixed
2010-10-31 17:51 fman Assigned To => fman
2011-03-18 19:09 fman Note Added: 0014038
2011-03-18 19:09 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker