Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001969TestLinkGeneralpublic2009-01-08 13:182009-01-20 05:19
Reporteramitkhullar 
Assigned Toschlundus 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 2 
Fixed in Version1.8 RC 3 
Summary0001969: The Execute / Results link on Navbar behave in incorrect manner
DescriptionPlease see the video attached for more details , on selecting a TP sometimes I found that the system behaves erratically poiting to the Test Plan Management page rather than Test Execute or Results page. If i go and change the Test Project and come back again to this Test Project it starts behaving fine.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon bug testlink.swf [^] (860,510 bytes) 2009-01-08 13:18

- Relationships

-  Notes
(0004962)
fman (administrator)
2009-01-08 17:32

Please do not attach only video files.
We need detailed description and steps to reproduce, to use our scarse time in an efficient way.
(0004969)
amitkhullar (reporter)
2009-01-08 17:46

This is an strange behaviour for Execute / Results links on NavBar pointing to the Test Plan Management Page. This doesnt occur everytime but I think that selecting the Test Plan (eg. A) which is on the top order of the Test Plan combo box has this issue, which get corrected if u choose some other Test Plan (e.g. B) open the Results page or Test Execute link and then come back to the main page by selecting the Home link in NavBar and then you can see by default the Test Plan on the main page becomes A instead of B and now whenyou click any of the Results or Test Execute link then the take you to theTest Plan mgmt page.

Hope this helps.

If still not clear watch the small .SWF file i attached here
(0004972)
amitkhullar (reporter)
2009-01-08 18:07

While facing this issue one more problem comes that you click the Add / Remove Test Cases in Test Plan it gives the error below.( might be something related to session or change of the Test Plan as specified earlier and the system gets confused.)
ERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4 - SELECT testplans.*,NH.name,NH.parent_id FROM testplans testplans, nodes_hierarchy NH WHERE testplans.id = NH.id AND testplans.id =

THE MESSAGE :: SQL [12] executed [took 0.0002 secs][all took 0.0112 secs]: SELECT testplans.*,NH.name,NH.parent_id FROM testplans testplans, nodes_hierarchy NH WHERE testplans.id = NH.id AND testplans.id = Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4
ERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND (UA.type=1 OR UA.type IS NULL) ORDER BY testsuite_id,NHB.node_order,tc_id,' at line 1 - SELECT NHB.parent_id AS testsuite_id, NHA.parent_id AS tc_id, NHB.node_order AS z, NHB.name, T.tcversion_id AS tcversion_id, T.id AS feature_id, T.node_order AS execution_order, TCV.version AS version, TCV.active, TCV.tc_external_id AS external_id, E.id AS exec_id, E.tcversion_number, E.tcversion_id AS executed, E.testplan_id AS exec_on_tplan, UA.user_id,UA.type,UA.status,UA.assigner_id,T.urgency, COALESCE(E.status,'n') AS exec_status FROM nodes_hierarchy NHA JOIN nodes_hierarchy NHB ON NHA.parent_id = NHB.id JOIN testplan_tcversions T ON NHA.id = T.tcversion_id JOIN tcversions TCV ON NHA.id = TCV.id LEFT OUTER JOIN executions E ON (NHA.id = E.tcversion_id AND E.testplan_id=T.testplan_id ) LEFT OUTER JOIN user_assignments UA ON UA.feature_id = T.id WHERE T.testplan_id= AND (UA.type=1 OR UA.type IS NULL) ORDER BY testsuite_id,NHB.node_order,tc_id,E.id ASC

THE MESSAGE :: SQL [14] executed [took 0.0003 secs][all took 0.0125 secs]: SELECT NHB.parent_id AS testsuite_id, NHA.parent_id AS tc_id, NHB.node_order AS z, NHB.name, T.tcversion_id AS tcversion_id, T.id AS feature_id, T.node_order AS execution_order, TCV.version AS version, TCV.active, TCV.tc_external_id AS external_id, E.id AS exec_id, E.tcversion_number, E.tcversion_id AS executed, E.testplan_id AS exec_on_tplan, UA.user_id,UA.type,UA.status,UA.assigner_id,T.urgency, COALESCE(E.status,'n') AS exec_status FROM nodes_hierarchy NHA JOIN nodes_hierarchy NHB ON NHA.parent_id = NHB.id JOIN testplan_tcversions T ON NHA.id = T.tcversion_id JOIN tcversions TCV ON NHA.id = TCV.id LEFT OUTER JOIN executions E ON (NHA.id = E.tcversion_id AND E.testplan_id=T.testplan_id ) LEFT OUTER JOIN user_assignments UA ON UA.feature_id = T.id WHERE T.testplan_id= AND (UA.type=1 OR UA.type IS NULL) ORDER BY testsuite_id,NHB.node_order,tc_id,E.id ASC Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND (UA.type=1 OR UA.type IS NULL) ORDER BY testsuite_id,NHB.node_order,tc_id,' at line 1
(0004991)
amitkhullar (reporter)
2009-01-12 18:58

Below is the debug infofor the $_REQUEST for the page planAddTC.php which shows
[tplan_id] => as empty. The switching / redirection of pages looses the tplanID.

debug 20090111 - \ - C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\daily\lib\plan\planAddTC.php --- Array
(
    [print_scope] => test_specification
    [edit] => testsuite
    [level] => testsuite
    [id] => 18354
    [tplan_id] =>
    [keywordsFilterType] => OR
    [PHPSESSID] => ojbu1t0a82abi4qpmhhd6p9j64
    [TL_lastTestProjectForUserID_2] => 15233
    [ys-planaddtc_15233_ext-comp-1001] => a:s%3A/15233/18337/18354
    [ys-undefinedext-comp-1001] => a:s%3A/15233
)
(0004993)
schlundus (reporter)
2009-01-13 05:17

I think it's related to the problem "masami" has reported
I've fixed this today. Please checkout and do a retest
(0004994)
amitkhullar (reporter)
2009-01-13 14:40

Hi,
This is an intermittent issue and seems to be fixed for now, in case it reappears will let u know.

Amit

- Issue History
Date Modified Username Field Change
2009-01-08 13:18 amitkhullar New Issue
2009-01-08 13:18 amitkhullar File Added: bug testlink.swf
2009-01-08 17:32 fman Note Added: 0004962
2009-01-08 17:32 fman Status new => feedback
2009-01-08 17:46 amitkhullar Note Added: 0004969
2009-01-08 18:07 amitkhullar Note Added: 0004972
2009-01-12 18:58 amitkhullar Note Added: 0004991
2009-01-13 05:17 schlundus Note Added: 0004993
2009-01-13 05:17 schlundus Status feedback => assigned
2009-01-13 05:17 schlundus Assigned To => schlundus
2009-01-13 14:40 amitkhullar Note Added: 0004994
2009-01-14 02:28 schlundus Status assigned => resolved
2009-01-14 02:28 schlundus Fixed in Version => next development 1.8 RC3
2009-01-14 02:28 schlundus Resolution open => fixed
2009-01-20 05:19 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker