Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001953TestLinkGeneralpublic2008-12-24 11:072010-05-01 20:34
Reporteraksinghv 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 2 
Fixed in Version1.9 Beta 2 
Summary0001953: Deprecated: Function ereg_replace() is deprecated in D:\tl_dev\testlink\lib\functions\lang_api.php on line 171
DescriptionHello,

I have installed following:
Apache 2.2.11
php php5.3.0 dated 2008/12/24 02:00:00 from http://windows.php.net/snapshots/ [^]
mysql 6.0.7

above is installed using WampServer 2.0f [http://www.wampserver.com/ [^]].

I get above error and i am listing it below:
Deprecated: Function ereg_replace() is deprecated in D:\tl_dev\testlink\lib\functions\lang_api.php on line 171

this is displayed for 1461 times before dispaying the login page. It takes about 7 seconds to display the login page. Even after entering correct password, it dispplays "Your session expired. Please login again". I tried cleaning up but again i am getting this. By the way after each password entry it displays
Deprecated: Function ereg_replace() is deprecated in D:\tl_dev\testlink\lib\functions\lang_api.php on line 171
 for 1461 times and then displays the login screen/session expired page. It takes about 5-7 seconds to display above page.

I guess there something to do with ereg function. Can this be fixed as PHP5.3 is going to become standard.

LEt me know if you need more information.


TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFF3.0.5
PHP Version5.3.0 alpha3
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
child of 0002083closedschlundus eregXXX calls should be avoided 

-  Notes
(0004880)
aksinghv (reporter)
2008-12-24 11:10

I have checked, if i select php as php5.2.8, it does not display above error and the page display takes <1-2seconds.
(0004883)
fman (administrator)
2008-12-24 18:13

We have not tested on mysql 6.0 neither php 5.3
I do my tests on PHP 5.2.6
(0004891)
schlundus (reporter)
2008-12-29 16:31
edited on: 2009-03-17 03:46

as 5.3 will surely take some time to become standard, because it's only alpha now we shouldn't worry about this now => 1.9

(0007418)
aksinghv (reporter)
2009-07-01 09:48

Hi,

PHP 5.3.0 is not released (Jun 30, 2009) [http://php.net [^]].
Do we plan to support it now?

Regards,
Anjani
(0007421)
aksinghv (reporter)
2009-07-01 22:34

PHP 5.3.0 is GOT released (Jun 30, 2009) [http://php.net [^]]. [^]. In the last post, i had written not.

Sorry for this.

~Anjani
(0007637)
fman (administrator)
2009-07-27 15:23

Oops commit without test, I'm sorry, just corrected and commited
(0007763)
schlundus (reporter)
2009-08-12 02:11

Still about 20 occurences of ereg-Functions
(0007798)
schlundus (reporter)
2009-08-19 02:48

All ereg_ related functions are removed, with the exception of connector.php from fckeditor.

Also all split and spliti functions are marked as deprecated
(0007882)
mhavlat (reporter)
2009-08-31 19:53

Andreas, should be marked as resolved with respect to 2083?
(0007891)
schlundus (reporter)
2009-09-01 01:54

The issue can be closed if the split and spliti functions are replaced.
Then we have to decide, what we do with the 3party components
(0008210)
guest (reporter)
2009-11-05 18:58

I am able to reproduce this issue on

XAMPP 1.7.2

Deprecated: Function ereg_replace() is deprecated in C:\xampp\htdocs\testlink\lib\functions\lang_api.php on line 173

Regards
Avinash
(0008211)
mhavlat (reporter)
2009-11-05 19:23

Andreas,
which thirdparty have the problem. We could look about update these components.
(0008217)
fman (administrator)
2009-11-05 23:10

1.9 will be compatibel with PHP 5.3, early versions NOT

- Issue History
Date Modified Username Field Change
2008-12-24 11:07 aksinghv New Issue
2008-12-24 11:07 aksinghv Browser => FF3.0.5
2008-12-24 11:07 aksinghv PHP Version => 5.3.0 alpha3
2008-12-24 11:10 aksinghv Note Added: 0004880
2008-12-24 18:10 fman Status new => assigned
2008-12-24 18:10 fman Assigned To => fman
2008-12-24 18:13 fman Note Added: 0004883
2008-12-29 16:31 schlundus Note Added: 0004891
2009-03-17 03:46 schlundus Note Edited: 0004891
2009-07-01 09:48 aksinghv Note Added: 0007418
2009-07-01 22:34 aksinghv Note Added: 0007421
2009-07-27 15:23 fman Note Added: 0007637
2009-07-27 15:24 fman Status assigned => resolved
2009-07-27 15:24 fman Fixed in Version => 1.9 (DEV)
2009-07-27 15:24 fman Resolution open => fixed
2009-08-12 02:11 schlundus Note Added: 0007763
2009-08-12 02:11 schlundus Status resolved => assigned
2009-08-12 02:11 schlundus Resolution fixed => reopened
2009-08-19 02:48 schlundus Note Added: 0007798
2009-08-31 19:52 mhavlat Relationship added child of 0002038
2009-08-31 19:52 mhavlat Relationship deleted child of 0002038
2009-08-31 19:52 mhavlat Relationship added child of 0002083
2009-08-31 19:53 mhavlat Note Added: 0007882
2009-09-01 01:54 schlundus Note Added: 0007891
2009-11-05 18:58 guest Note Added: 0008210
2009-11-05 19:23 mhavlat Note Added: 0008211
2009-11-05 23:10 fman Note Added: 0008217
2009-12-07 00:36 fman Status assigned => resolved
2009-12-07 00:36 fman Resolution reopened => fixed
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker