Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001934TestLinkTest Plan (builds, milestones, test assign)public2008-12-17 05:322010-10-09 08:01
Reporterkcurran 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 2 
Fixed in Version1.9 RC 1 
Summary0001934: After adding large number of Test Cases ( 0000755:0001500), get fatal error when trying to assign users or execute
DescriptionThe following error when trying to open tree for assignment or execute

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 196608 bytes) in C:\xampplite\htdocs\testlink_18RC2\testlink\lib\functions\object.class.php on line 55
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
has duplicate 0003053closedmhavlat The number of Test Cases that can be added to a Test Plan is VERY Low 

-  Notes
(0004862)
fman (administrator)
2008-12-18 00:44

Please:
1. what are a large number of test cases ?
2. what tree manager are you using ?

3. is possible to have your db ?
(0004864)
kcurran (reporter)
2008-12-18 00:54

1: I imported 5000+ test cases, then added 1500-2000 test cases to the test plan which resulted in the error.
I have since reduced the number of test cases ( to approximately 500) from the test plan ( which worked) and was able to see the tree for user assignment or execution.
2: using the default tree

3: No can't share the db
(0004955)
fman (administrator)
2009-01-08 01:32

What tree engine are you using ?
(0004959)
kcurran (reporter)
2009-01-08 02:46

$tlCfg->treemenu_type = 'EXTJS';

Also, I noticed the same problem when I added a test suite with 900 test cases to the plan
(0005033)
mhavlat (reporter)
2009-01-16 19:32

Workaround: You use short memory limit. Please extend max memory in php.ini. The common value is 32M, but 64M in you case is better.

Performance issue; target release 1.9
(0008656)
Jgaudreau (reporter)
2010-01-12 23:52

I will try to check on that with our technical assistance department, I'll send them your suggestion to work around the problem.

Thanks for the help, if it doesn't work, I will let you know to see what is the cause of my problem.

Thank you,
Jonathan
(0011817)
fman (administrator)
2010-10-09 08:01

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2008-12-17 05:32 kcurran New Issue
2008-12-17 05:32 kcurran Browser => IE
2008-12-18 00:44 fman Note Added: 0004862
2008-12-18 00:54 kcurran Note Added: 0004864
2009-01-08 01:32 fman Note Added: 0004955
2009-01-08 02:46 kcurran Note Added: 0004959
2009-01-16 19:32 mhavlat Note Added: 0005033
2009-01-16 19:32 mhavlat Severity crash => major
2009-01-16 19:32 mhavlat Status new => acknowledged
2010-01-12 23:40 mhavlat Relationship added has duplicate 0003053
2010-01-12 23:52 Jgaudreau Note Added: 0008656
2010-09-08 19:27 fman Status acknowledged => resolved
2010-09-08 19:27 fman Fixed in Version => 1.9 RC 1
2010-09-08 19:27 fman Resolution open => fixed
2010-09-08 19:27 fman Assigned To => fman
2010-10-09 08:01 fman Note Added: 0011817
2010-10-09 08:01 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker