Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001927TestLinkTest Plan (builds, milestones, test assign)public2008-12-11 16:512010-05-01 20:31
Reporternothlev 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 3 
Summary0001927: filter on keyword - Filter tree when add/remove testcases - KO
DescriptionWhen filter on keyword, adding/removing testcases from testplan, the tree doesnt filter. I am using TL 1.7.0, and in tis version, only suites that holds testcases that match the filter is shown. I hope the same funktionality is planned for TK 1.8.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 7.0
PHP Version?
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0004837)
mhavlat (reporter)
2008-12-11 17:11

Which tree component are you using?
(0004838)
nothlev (reporter)
2008-12-11 17:23

I use the default tree.

tlCfg->treemenu_type = 'EXTJS';

I have not tried the other types (yet)
(0004839)
nothlev (reporter)
2008-12-11 17:34

I tried the JTREE component, and then it works fine :-)
(0004840)
fman (administrator)
2008-12-12 01:32

My view of this problem is this:
If you want to use on demand tree loading using Ajax to have BETTER Performance (EXT-JS), you start loading only first tree level, and load other pieces only when user clicks on.
This is the way tree is builded on add/remove test cases to test plan
feature.
But if you want to set a filter that must prune a whole branch from first level, because no test case on branch meets condition you can NOT KNOW THIS while loading first level, but need to INSPECT WHOLE tree, thing that you do not want to do to have better performance.

Hope now is clear

Suggestion/solutions are welcomed.
(0004911)
schlundus (reporter)
2009-01-06 04:09

I also have no easy and quick solution at hand, so i propose to postpone this to 1.9 where we surely revisit the tree's again
(0004937)
mhavlat (reporter)
2009-01-06 21:02
edited on: 2009-01-06 21:04

Is not possible to force tree to be expanded in the case that filter is used?

Maybe filtering string could be stored in session data for ajax calls ...

(0008438)
mhavlat (reporter)
2009-12-08 19:48

Reminder sent to: fman

Is it the case you asked me?

- Issue History
Date Modified Username Field Change
2008-12-11 16:51 nothlev New Issue
2008-12-11 16:51 nothlev Browser => IE 7.0
2008-12-11 16:51 nothlev PHP Version => ?
2008-12-11 17:11 mhavlat Note Added: 0004837
2008-12-11 17:23 nothlev Note Added: 0004838
2008-12-11 17:34 nothlev Note Added: 0004839
2008-12-11 19:01 mhavlat Severity feature request => minor
2008-12-12 01:32 fman Note Added: 0004840
2008-12-12 01:33 fman Status new => feedback
2009-01-06 04:09 schlundus Note Added: 0004911
2009-01-06 21:02 mhavlat Note Added: 0004937
2009-01-06 21:04 mhavlat Note Edited: 0004937
2009-12-08 19:48 mhavlat Note Added: 0008438
2009-12-08 19:50 mhavlat Product Version 1.8 RC 2 =>
2009-12-16 05:45 fman Status feedback => assigned
2009-12-16 05:45 fman Assigned To => fman
2010-02-28 18:31 fman Summary Filter tree when add/remove testcases => filter on keyword - Filter tree when add/remove testcases - KO
2010-02-28 18:36 fman Status assigned => resolved
2010-02-28 18:36 fman Fixed in Version => 1.9 Beta 3 (Next Beta)
2010-02-28 18:36 fman Resolution open => fixed
2010-05-01 20:31 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker