Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000192TestLinkNew Featurepublic2005-10-19 23:102010-05-01 20:36
Reporterjavabee 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 2 
Summary0000192: User should be able to edit the test case while executing it
DescriptionA lot of time when user executing the test case, user may find the expected result need to be modified. Currently, test case is not editable in the executing window.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0000497closedfman It should be possible to design and execute test cases simultaneously 

-  Notes
(0000259)
fman (administrator)
2005-10-20 09:20

IMHO thats OK, you need to change the spec and the update modified testcase
(0000342)
buddy1515 (reporter)
2005-11-17 09:39

...and after editing, there should be an option to update TC in mgttestcase.
(0000343)
fman (administrator)
2005-11-17 10:11

I think my words were misunderstood:

I don't think this request has to be implemented.
If you found you want to change something will you are executing you have to:

1. abort execution
2. modify specification
3. update Test Plan
4. re-rerun execution


regards
(0000344)
buddy1515 (reporter)
2005-11-17 11:51

you described the current procedure;
from users point of view it's not only very time consuming to do so,
but also you have to leave the test execution mode.

it would be more efficient and user friendly to have functions to
modify the currently executed testcase and
after saving to have the possibility to
update the testcase in the pool (mgttestcase).
(0000345)
fman (administrator)
2005-11-17 12:34

IMHO, the need to change an expected result have to be an exception (or other tc parameters as steps, etc), not the rule then If I've 10.000 TC to execute, how many of then (if the TC has been developed with accurancy) can have the expected result to be changed nor more thant 1% or 5%.

Then the issue about "... I must leave execution mode ...", don't sustain.
Just leave this TC, and continue with the others.
And This feature will be only useful for the testers that have rights to
change Test Cases.

Again, IMHO, to do a job with quality you need to spend time, planning and
development.

Anyway if we choose to add it, no problem, but this has lower priority for me.
(0000346)
buddy1515 (reporter)
2005-11-17 13:06

I agree, Perhaps we work sloppy ;-).
Sometimes the description is inexactly or was formulated misleading. In my own experience it was sometimes the case, that a test case specification should be modified.
(0000347)
scorpfromhell (reporter)
2005-11-17 14:04

It happens almost all the times over here where I work and many of my client's places :-)

Hence we want to use a tool to manage our testing, so that processes are enforced on our teams and all sloppiness is removed.

I agree with fman completely, planning is very much essential but sticking to them is even more important and the toughest job! ;-)
(0001345)
joni_piter (reporter)
2007-02-26 18:56

While we should expect not having to change our specification lots of times, in turns out that in real world it happens a lot more than we expect. This happens due to a variety of reasons, and that's why developing/Testing paradigms are changing. We now talk about Exploratory Testing, Agile Development, in which the testing activity is much more about gaining information about the product (more than just specs verification), and the better tests (stronger, more able to expose important defects) are often imagined during the course of testing (see for example http://www.kaner.com/pdfs/GoodTest.pdf [^])
See also related issue: 0000497

I'm not saying that this is mandatory feature, just that it would help to place TestLink in the front line of state-of-the-art tester tools.
(0001346)
fman (administrator)
2007-02-26 19:00

1. as you can see this morning I've added the relationship to 497

2.If we accept not having the fancy FCKeditor, when you exec and edit, I see no big problem on doing this kind of development.

Anyway this is a new feature request, and will be evalueated to be included
on future versions after 1.7 release


Best Regards
(0001349)
joni_piter (reporter)
2007-02-26 19:13

Thank you.
PS: I added my last note mainly for other users who monitor this issue, I know you are aware of all I said :)

- Issue History
Date Modified Username Field Change
2005-10-19 23:10 javabee New Issue
2005-10-20 09:20 fman Note Added: 0000259
2005-11-17 09:39 buddy1515 Note Added: 0000342
2005-11-17 10:11 fman Note Added: 0000343
2005-11-17 11:51 buddy1515 Note Added: 0000344
2005-11-17 12:34 fman Note Added: 0000345
2005-11-17 13:06 buddy1515 Note Added: 0000346
2005-11-17 14:04 scorpfromhell Note Added: 0000347
2007-02-19 23:23 mhavlat Project Testlink 1.6.x => TestLink
2007-02-26 16:12 fman Relationship added related to 0000497
2007-02-26 18:56 joni_piter Note Added: 0001345
2007-02-26 19:00 fman Note Added: 0001346
2007-02-26 19:13 joni_piter Note Added: 0001349
2009-04-21 16:34 fman Status new => resolved
2009-04-21 16:34 fman Fixed in Version => 1.9 (DEV)
2009-04-21 16:34 fman Resolution open => fixed
2009-04-21 16:34 fman Assigned To => fman
2010-05-01 20:36 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker