Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001913TestLinkNew Featurepublic2008-12-06 02:022012-11-25 10:01
Reporteryukihito 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version1.8 RC 4 
Summary0001913: Feature to be able to filter all previous builds.
DescriptionWould like to have a feature to be able to filter all previously run builds on the tree menu from navigator.
Such as, filter within all previous builds, if test case was pass/fail/blocked.
If Navigator can filter this, tester can see which portion of the test still needs to be run, or
which portion of test case has passed/failed/blocked without loading the actual content.

Currently, the system works as if tester wants to know if the test case was run within the history of builds,
he would have to actually load the test case content to look at the build legends.

If possible of filtering previous test case builds in tree view, tester does not need to actually check each test case content
as well as, server does not have to load the content every time tester needs to check.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0004778)
fman (administrator)
2008-12-07 18:16

Please explain with a detailed example, in order to undertand better your request
(0004780)
yukihito (reporter)
2008-12-07 21:43

Such as in case, I have a team that checks projects translation, the team does not check the whole project translation on every build because the whole project is too large as well as every build is released once a week. simply there is not enough time to go through the whole build checking every testcase within a weeks timespan. They would check a portion of the project at a time through the whole span of the project.

In this case, with the current setup of build execution history, the only way to recognize if the previous builds have been run before is by checking the actual testcase on the right side frame. Because of this, the testers are asked to load the actual content of each testcase or test suite on the right side frame every time they want to go over and check which portion they have finished. Because of this, the server is asked to generate the whole actual testcase every time they check.

In case a filter can be applied to the left side frame tree structure to filter out testcases that have been run in all previous builds aswell, testers do not have to load build history on the right side frame to check.
(0004781)
yukihito (reporter)
2008-12-07 21:48

example: translation team which checks translation throughout the project.

Current: if team executed some portions of the project testing in last weeks build, they have to actually generate the testcases on the right side frame to check which testcases were run, passed/failed/blocked on this weeks build.

Change: team that executed some portions of the project on last weeks build will filter out with setting [filter all previous builds] -> [Pass]. In this case, team does not have to generate actual testcase on right side frame to check which ones they have already run and keep going on with testing.
(0004853)
yukihito (reporter)
2008-12-16 02:51

Since this seems to have not been worked on, I'll throw in another example to get a better explanation.

In case, there is a problem on whatever is being tested, it gets alerted to the developers and then the problem gets worked on for 3 or so builds before it's fixed.
After 3 builds, the tester would go back to pass the testcase but in this case, with the current system. The test has to remember which testcase was set as failed on an additional note, or another system to log which portion of the test he has failed and needs verification. since he can't figure it out by filtering by fail on all previous builds on the left tree menu. In case the tester is doing a 300+ or so huge test, this process of having to go to the actual testcase (not to mention loading the actual content on the right side frame) afterwards to pass them, rather than filtering failed and seeing easily which testcase didn't succeed in previous builds is a waste of time and would endanger the project time limit.
(0004884)
fman (administrator)
2008-12-28 00:34

please get code from CVS and test new implementation (committed 20081227)
and let us know
(0005555)
yukihito (reporter)
2009-02-20 04:15

I have checked this in RC4 and I see the feature under the filters in execution but wasn't able to confirm the function working yet.
(0005589)
mhavlat (reporter)
2009-02-23 18:58

yukihito, do you plan to get more results? So Francisco could close the issue.

- Issue History
Date Modified Username Field Change
2008-12-06 02:02 yukihito New Issue
2008-12-07 18:16 fman Note Added: 0004778
2008-12-07 21:43 yukihito Note Added: 0004780
2008-12-07 21:48 yukihito Note Added: 0004781
2008-12-08 17:25 NOTALLOWED-admin Tag Attached: Testlink 1.8 beta
2008-12-16 02:51 yukihito Note Added: 0004853
2008-12-22 17:59 fman Status new => assigned
2008-12-22 17:59 fman Assigned To => fman
2008-12-28 00:34 fman Note Added: 0004884
2008-12-28 00:34 fman Status assigned => feedback
2009-02-20 04:15 yukihito Note Added: 0005555
2009-02-23 18:58 mhavlat Note Added: 0005589
2009-02-26 02:26 fman Status feedback => resolved
2009-02-26 02:26 fman Fixed in Version => 1.8 RC 4
2009-02-26 02:26 fman Resolution open => fixed
2009-04-05 00:46 mhavlat Status resolved => closed
2012-11-25 10:01 fman Tag Detached: Testlink 1.8 beta



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker