Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001903TestLinkUsers and Rightspublic2008-11-26 13:392009-01-20 05:19
ReporterOcean 
Assigned Toschlundus 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version1.8 RC 2 
Summary0001903: Can't assign one user to one project with <no rights>
DescriptionI can't assign one user to one project with <no rights>, it will change back <inherited>xxx after I click "Update" in Test Project roles. I want to keep somebody can not see information of one specific project.
Steps To Reproduce1. Create a new user named A with leader role
2. Create a new project named B
3. Change Test Project to B to assign roles in Assign Test Project roles
4. Assign user A to <no rights>
5. Click "Update"

A's role will be <Inherited>leader.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserInternet Explorer 7
PHP Version5.2.6
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
has duplicate 0002065closedschlundus Test Project Level permissions display issue 

-  Notes
(0004711)
schlundus (reporter)
2008-11-27 03:49

Bug while reading the rights of a role caused by a optimization done by me. I've forgot the "<no rights>"-Role which has NO rights (-: So my join didn't work:

Fix role.class.php
replace
$query .= " JOIN role_rights b ON a.id = b.role_id JOIN rights c ON b.right_id = c.id ";
with
$query .= " LEFT OUTER JOIN role_rights b ON a.id = b.role_id LEFT OUTER JOIN rights c ON b.right_id = c.id ";

- Issue History
Date Modified Username Field Change
2008-11-26 13:39 Ocean New Issue
2008-11-26 13:39 Ocean Browser => Internet Explorer 7
2008-11-26 13:39 Ocean PHP Version => 5.2.6
2008-11-26 23:37 schlundus Status new => assigned
2008-11-26 23:37 schlundus Assigned To => schlundus
2008-11-27 03:14 schlundus Status assigned => acknowledged
2008-11-27 03:49 schlundus Status acknowledged => resolved
2008-11-27 03:49 schlundus Fixed in Version => next development 1.8 RC 2
2008-11-27 03:49 schlundus Resolution open => fixed
2008-11-27 03:49 schlundus Note Added: 0004711
2009-01-20 05:19 mhavlat Status resolved => closed
2009-02-06 01:46 schlundus Relationship added has duplicate 0002065



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker