Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001894TestLinkInstallerpublic2008-11-20 10:062009-02-03 07:09
Reporterghudson11 
Assigned Tofman 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version1.8 RC 3 
Summary0001894: DB Migration script for 1.74 to 1.8 RC1 is not functional
DescriptionIssue: attempting to use auto migration script to convert 1.74 data to RC1 1.8 does not ever finish.

Steps:
1. download 1.8 RC1
2. un-tar
3. configure for http
4. click migrate from 1.72 or later to 1.8
5. Save book mark
6. click upgrade DB (db is updated)
7. Go back to book mark and click (STEP THREE: After successful execution of STEP TWO, return to this page and click here to start data migration/update)
8. Enter DB Info and next
Result:
Connecting to Testlink 1.7.2 (source) database. - testlink - OK!
Due to total test cases quantity Migration process will take at least 15 min

Problem starts here: There is no way to continue from this point, I believe there is a button missing or the script seems to die at this point. Monitoring the db status I never see a connection made by testlink.
Additional InformationChecking PHP version: OK! ( 5.0.0 [minimun version] <= 5.1.6 [your version] )
Checking if Register Globals = OFF: OK!
Checking PHP DB extensions OK!
Checking if sessions are properly configured: OK!
Checking if ../../../gui/templates_c directory exists: OK!
Checking if ../../../gui/templates_c directory is writable: OK!
Checking if ../../../logs directory exists: OK!
Checking if ../../../logs directory is writable: OK!
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserUsing FF 3.0
PHP Version5.1.6
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon FireShot capture #102 - 'TestLink' - 172_16_32_40_testlink_install_migration_migrate_17_migrate_17_to_18_php.jpg [^] (45,207 bytes) 2008-11-21 04:40

- Relationships

-  Notes
(0004753)
fman (administrator)
2008-12-03 02:25

Please send dump of your 1.7.4 db to francisco.mancardi@gmail.com
(0004757)
ghudson11 (reporter)
2008-12-03 06:36

1.7.4 DB Dump delivered to francisco.mancardi@gmail.com
(0004846)
ghudson11 (reporter)
2008-12-13 09:35

Was my db dump received?
(0004847)
fman (administrator)
2008-12-13 16:42

Yes, but I'm having problems importing file on my db.
I will try again and give you feed back.
(0004850)
fman (administrator)
2008-12-15 16:39

I've tested on my windows laptop, and migration works without problems.
Can you check amount of memory on php.ini ?
(0004912)
tanweernoor (reporter)
2009-01-06 04:10

generally it takes time in migration... for 20,000 test cases it took around 8 hours while migrating from 1.7.1 to 1.8 RC1
(0004913)
zxcvb (reporter)
2009-01-06 19:23

I had the same issue via migrating from 1.7.4 to 1.8RC2.
It may cause by php version(5.1.6). The migration script was stuck by the function memory_get_peak_usage in migrate_17_to_18.php and migrate_17_to_18_functions.php. This function is not functional in php 5.1.6 but in PHP 5(>=5.2.0). After removing it from the script or changing it to memory_get_usage, the migration was proceeded and successful.

http://cn2.php.net/memory_get_peak_usage [^]
(0004940)
ghudson11 (reporter)
2009-01-07 02:32

Thanks guys, I will try your suggestions.
(0004945)
fman (administrator)
2009-01-07 02:53

Thanks for your help, I will fix code to test for memory* functions

Anyway please migrate to 5.2.x, because you need this version to use Ajax Tree that will be in near future ONLY TREE supported for tree menu

- Issue History
Date Modified Username Field Change
2008-11-20 10:06 ghudson11 New Issue
2008-11-20 10:06 ghudson11 Browser => Using FF 3.0
2008-11-20 10:06 ghudson11 PHP Version => 5.1.6
2008-11-21 00:22 fman Status new => assigned
2008-11-21 00:22 fman Assigned To => fman
2008-11-21 04:40 ghudson11 File Added: FireShot capture #102 - 'TestLink' - 172_16_32_40_testlink_install_migration_migrate_17_migrate_17_to_18_php.jpg
2008-12-03 02:25 fman Note Added: 0004753
2008-12-03 06:36 ghudson11 Note Added: 0004757
2008-12-13 09:35 ghudson11 Note Added: 0004846
2008-12-13 16:42 fman Note Added: 0004847
2008-12-15 16:39 fman Note Added: 0004850
2009-01-06 04:10 tanweernoor Note Added: 0004912
2009-01-06 19:23 zxcvb Note Added: 0004913
2009-01-07 02:32 ghudson11 Note Added: 0004940
2009-01-07 02:53 fman Note Added: 0004945
2009-01-08 01:31 fman Status assigned => resolved
2009-01-08 01:31 fman Fixed in Version => next development 1.8 RC3
2009-01-08 01:31 fman Resolution open => fixed
2009-01-20 05:19 mhavlat Status resolved => closed
2009-02-03 07:09 mhavlat Note Added: 0005210
2009-02-03 07:11 mhavlat Note Deleted: 0005210



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker