Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001889TestLinkGeneralpublic2008-11-19 21:452009-01-20 05:24
Reporterpartymungo 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version 
Summary0001889: Testexecution not possible
DescriptionHi,
i try to migrate from TL 1.8Beta2 to TL 1.8RC1 and got a different behavior in test execution. After pressing the button [execute And save results] in test execution screen, i get the following messages in apache2 access.log:

TL 1.8 Beta2
127.0.0.1 - - [18/Nov/2008:17:14:38 +0100] "POST /testlink/lib/execute/execSetResults.php?version_id=55&level=testcase&id=54&build_id=4&include_unassigned=0&filter_status= HTTP/1.1" 200 82050 "http://localhost/testlink/lib/execute/execSetResults.php?version_id=55&level=testcase&id=54&build_id=4&include_unassigned=0&filter_status=" [^] "Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.1.17) Gecko/20080921 SUSE/2.0.0.17-0.1 Firefox/2.0.0.17"

127.0.0.1 - - [18/Nov/2008:17:14:38 +0100] "POST /testlink/lib/api/xmlrpc.php HTTP/1.0" 200 441 "-" "xmlrpclib.py/1.0.1 (by www.pythonware.com)"


TL 1.8 RC1
127.0.0.1 - - [18/Nov/2008:17:09:03 +0100] "POST /testlink/lib/execute/execSetResults.php?version_id=119&level=testcase&id=118&build_id=3&include_unassigned=0&filter_status= HTTP/1.1" 500 - "http://localhost/testlink/lib/execute/execSetResults.php?version_id=119&level=testcase&id=118&build_id=3&include_unassigned=0&filter_status=" [^] "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.17) Gecko/20080921 SUSE/2.0.0.17-0.1 Firefox/2.0.0.17"


Is is possible that my local XMLRPC server (which will execute a testscript depending on testid) will not be called in TL 1.8RC1, because of the missing POST (/lib/api/xmlrpc.php)?
Additional InformationOS: openSUSE 10.3 32 bit
kernel: 2.6.22.19-0.1-default
PHP: PHP 5.2.6 with Suhosin-Patch 0.9.6.2 (cli)
MySQL server version: 5.0.45 SUSE MySQL RPM
Apache server version: 2.2.4 (Linux/SUSE)
Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.17)
Gecko/20080921 SUSE/2.0.0.17-0.1
Firefox/2.0.0.17

TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox/2.0.0.17
PHP Version5.2.6
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon QS_dispatcher.py [^] (2,970 bytes) 2008-11-20 17:18

- Relationships
related to 0001901closedfman Refactor function (executeTestCase()) contributed by manish 

-  Notes
(0004664)
azl (administrator)
2008-11-20 04:57

It looks like in the first case you executed a test through the API using a python script and didn't do so in the second case.

The UI never passes executions through the API. In the first case it appears you had an external script that executed a test case through the API.

Is there a problem you are seeing?
(0004665)
azl (administrator)
2008-11-20 04:58

Please provide more detail.
(0004672)
partymungo (reporter)
2008-11-20 17:39
edited on: 2008-11-20 17:40

Hi azl,
thanks for your response. To start a test script by pressing the [test execute and save results button] in TL 1.8Beta2 i do the following changes (according to issue id 0000056):

1. "/gui/template/execute/execSetResults.tpl"
Add: {assign var="test_automation_enabled" value=true}
This will enable the button.

2. "custom_config.inc.php"
Set: $tlCfg->exec_cfg->enable_test_automation = ENABLED;

2. "third_party/phpxmlrpc/lib/xmlrpc.inc"
I set $connectionserver='localhost' and connectport=5043.
Maybe it is also possible to use custom fileds "tc_server_port" and "tc_server_host", but I can't bring it in function by using the custom fields, so i set the values directly in xmlrpc.inc

3. Start a simple XMLRPC server (code see attached file)
This server takes two parameters
Test case name
Test case id
According to the test id the server will trigger a test execution script and return the test result "blocked". If the test execution script is properly started, it returns the test result "in work" and after finishing the the final result (ok, failed) by using the TL API (reportTCResult).

This solution works very fine in TL 1.8Beta2.

The same aaproach in TL 1.8RC1 will not work, the XMLRPC server will not triggered.

(0004674)
fman (administrator)
2008-11-21 00:04

Please look on common.php I think some includes regarding xmlrpc has been commented.

Please let us know
(0004685)
partymungo (reporter)
2008-11-21 17:55

Hi fman,
you make my day ... many thanks for the hint. That was the "problem". After uncomment the function "executeTestCase" (line 834) and the line 809 - 813 in common.php, the XMLRPC server will be triggered again.

What I'm observe now, is that it is not longer possible to return test results (neither thru XMLRPC server nor thru the API), but I will take a deeper look at this behavior.
(0004699)
fman (administrator)
2008-11-25 01:45

We have added in a quick and dirty way this contribution time ago.
It would be great if you are able to help us to have it up and running.
Some step by step doc will be a must
(0004705)
fman (administrator)
2008-11-26 00:09

need to create a new option to include or not this code
(0004706)
fman (administrator)
2008-11-26 01:45

Reminder sent to: partymungo

I would like to send you a refactoring of code, asking you to do some tests
Please contact me at francisco.mancardi@gmail.com if you can help me. Then I will send you the code


thanks

- Issue History
Date Modified Username Field Change
2008-11-19 21:45 partymungo New Issue
2008-11-19 21:45 partymungo Browser => Firefox/2.0.0.17
2008-11-19 21:45 partymungo PHP Version => 5.2.6
2008-11-20 04:17 schlundus Status new => assigned
2008-11-20 04:17 schlundus Assigned To => azl
2008-11-20 04:57 azl Note Added: 0004664
2008-11-20 04:58 azl Note Added: 0004665
2008-11-20 04:58 azl Status assigned => feedback
2008-11-20 17:18 partymungo File Added: QS_dispatcher.py
2008-11-20 17:39 partymungo Note Added: 0004672
2008-11-20 17:40 partymungo Note Edited: 0004672
2008-11-21 00:04 fman Note Added: 0004674
2008-11-21 17:55 partymungo Note Added: 0004685
2008-11-25 01:45 fman Note Added: 0004699
2008-11-26 00:08 fman Status feedback => assigned
2008-11-26 00:08 fman Assigned To azl => fman
2008-11-26 00:09 fman Status assigned => resolved
2008-11-26 00:09 fman Resolution open => fixed
2008-11-26 00:09 fman Note Added: 0004705
2008-11-26 01:45 fman Note Added: 0004706
2008-11-26 01:51 fman Relationship added related to 0001901
2009-01-20 05:24 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker