Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001863TestLinkTest Specificationpublic2008-11-12 13:572010-10-09 08:01
Reporteramitkhullar 
Assigned Tofman 
PriorityhighSeverityfeature requestReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version 
Summary0001863: Import test cases - option to force check for duplicate/existing Test Case Titles on different test suites
DescriptionI had raised an issue (0001832) earlier but dint test it in this scenario, what problem I am facing is that we normally have distinct Test Case ID's for each test case. Reason being , may be the same test case is present in multiple test plans so it shud have the same Test Case ID ( TL ID here)for correct mapping every where rather than creating multiple copies of it in different Test Suites and then mapping them to Test Plan.


Say I have a Test Suite - TC structure as below

TS1
  --- TS2
       --- TC 1
       --- TC 2
TS3
  --- TS4
       --- TC 3

Now If I go and create a new test case under the TS4 test suite with the name similar to TC 1 or TC 2 it allows to create the same, which shudnt be the case.
The same thing happens with import also.

What I would suggest is that there should be a check box setting while importing Test Cases or a cfg setting which should not allow any redundant TC Names ( not even in different Test Suites ). The existing cfg setting works at only at same TS level.e.g. TS 2 denies same name TC both in importing as well as self creation of test case.
 
Hope you understand the issue.

Amit
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesxml file icon 1.196-Bug Retest.xml [^] (1,290 bytes) 2008-11-12 16:23
jpg file icon test case import.jpg [^] (71,227 bytes) 2008-11-12 16:23

- Relationships
related to 0003646closedfman Import of Test Suite allows duplicate test suite name 

-  Notes
(0004591)
amitkhullar (reporter)
2008-11-12 16:25

Please find the attached files I used for importing and the result in a snapshot.
The Import actually renames the issue with a timestamp when under the same test suite but imports it as it is in another Test Suite.

I have highlighted with Yellow and Green color in the pic.
(0004594)
fman (administrator)
2008-11-12 19:14

This is not a bug, but a feature request
(0011816)
fman (administrator)
2010-10-09 08:01

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2008-11-12 13:57 amitkhullar New Issue
2008-11-12 16:23 amitkhullar File Added: 1.196-Bug Retest.xml
2008-11-12 16:23 amitkhullar File Added: test case import.jpg
2008-11-12 16:25 amitkhullar Note Added: 0004591
2008-11-12 19:14 fman Note Added: 0004594
2008-11-12 19:15 fman Severity major => feature request
2008-11-12 19:15 fman Summary Import doesnt check for duplicate/existing Test Case Titles => Import test cases - option to force check for duplicate/existing Test Case Titles on different test suites
2008-11-14 02:45 fman Status new => assigned
2008-11-14 02:45 fman Assigned To => fman
2009-03-24 11:45 amitkhullar Note Added: 0005959
2009-04-12 03:02 amitkhullar Priority normal => high
2009-04-12 03:04 amitkhullar Note Added: 0006343
2010-02-21 04:13 amitkhullar Note Deleted: 0005959
2010-02-21 04:13 amitkhullar Note Deleted: 0006343
2010-08-02 08:00 amitkhullar Relationship added related to 0003646
2010-09-08 19:52 fman Status assigned => resolved
2010-09-08 19:52 fman Resolution open => won't fix
2010-10-09 08:01 fman Note Added: 0011816
2010-10-09 08:01 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker