Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001860TestLinkTest Plan (builds, milestones, test assign)public2008-11-11 19:382009-01-20 05:19
Reporteramitkhullar 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version1.8 RC 3 
Summary0001860: Test Case Assignment Page not functioning properly.
DescriptionIf you create a test plan with lot of sub test suites (nested inside it ), when you try to assign those test cases for execution to a user. See the image attached , on the left side you see lot of nested test suite names , none of them is displayed on the right pane, only the last level of the test suite is displayed.

I have marked 3 test suites in yellow box on left pane in pic, only those suites which are the last node of a tree before the test case are displayed. In earlier daily releases this was fixed and complete structure was there at time of test case execution assignment.

If this is still not clear please let me know.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon test suit assignment.jpg [^] (205,319 bytes) 2008-11-11 19:38


zip file icon fix-1860.zip [^] (8,071 bytes) 2008-11-19 15:39

- Relationships

-  Notes
(0004580)
amitkhullar (reporter)
2008-11-11 19:40

http://www.testlink.org/mantis/view.php?id=1720 [^] , u had implemented this functionality here and this was working fine.

Amit
(0004581)
amitkhullar (reporter)
2008-11-11 19:52

Found few errors in the events log :

Log level WARNING
Timestamp 11/11/2008 17:20:39
Source GUI
Description E_NOTICE Undefined offset: 9 - in /usr/local/apache2/htdocs/testlink_18RC1/gui/templates_c/%%D3^D38^D385932E%%tc_exec_assignment.tpl.php - Line 225

****************************************************************
Log level WARNING
Timestamp 11/11/2008 17:20:39
Source GUI
Description E_NOTICE Undefined index: key - in /usr/local/apache2/htdocs/testlink_18RC1/gui/templates_c/%%D3^D38^D385932E%%tc_exec_assignment.tpl.php - Line 61
*******************************************************************
Log level WARNING
Timestamp 11/11/2008 17:20:39
Source GUI
Description E_NOTICE Undefined index: children_testsuites - in /usr/local/apache2/htdocs/testlink_18RC1/lib/functions/specview.php - Line 675
*******************************************************************

Probably these may be causing this issue.

Amit
(0004582)
fman (administrator)
2008-11-11 23:04

I will check, probably is a bug due to some last minute refactoring
(0004584)
fman (administrator)
2008-11-11 23:09

is possible to send zip dump of your DB to francisco.mancardi@gmail.com ?
(0004646)
fman (administrator)
2008-11-19 15:39

please use attached fix and give us some feedback
(0004648)
amitkhullar (reporter)
2008-11-19 16:46

Thanks this is working now.

Amit
(0004786)
schlundus (reporter)
2008-12-09 03:52

fix is already include in CVS

- Issue History
Date Modified Username Field Change
2008-11-11 19:38 amitkhullar New Issue
2008-11-11 19:38 amitkhullar File Added: test suit assignment.jpg
2008-11-11 19:40 amitkhullar Note Added: 0004580
2008-11-11 19:52 amitkhullar Note Added: 0004581
2008-11-11 23:03 fman Status new => assigned
2008-11-11 23:03 fman Assigned To => fman
2008-11-11 23:04 fman Note Added: 0004582
2008-11-11 23:09 fman Note Added: 0004584
2008-11-19 15:39 fman File Added: fix-1860.zip
2008-11-19 15:39 fman Note Added: 0004646
2008-11-19 15:39 fman Status assigned => feedback
2008-11-19 16:46 amitkhullar Note Added: 0004648
2008-12-09 03:52 schlundus Status feedback => resolved
2008-12-09 03:52 schlundus Fixed in Version => next development 1.8 RC3
2008-12-09 03:52 schlundus Resolution open => fixed
2008-12-09 03:52 schlundus Note Added: 0004786
2009-01-20 05:19 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker