Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001848TestLinkReportspublic2008-11-10 14:362009-01-20 05:19
Reporteramitkhullar 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 1 
Fixed in Version1.8 RC 2 
Summary0001848: Charts not working
DescriptionThe Charts link when clicked doesn't display any thing but the text only.
It was earlier working in 1.8 beta 3

Please look at the attachment.

Amit
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon charts.JPG [^] (56,046 bytes) 2008-11-10 14:36


zip file icon fix-1848.zip [^] (6,110 bytes) 2008-11-13 22:33

- Relationships
related to 0001851closedfman pCharts gives divide by 0 error when no test case has been executed 
related to 0001861closedfman When I use Results-->Charts, I got a frozen window 

-  Notes
(0004559)
amitkhullar (reporter)
2008-11-10 14:37

Browser is Firefox 3.0.3
(0004564)
fman (administrator)
2008-11-10 19:34

1. third party component has been chande to pChart, and works in a different way
   => no data => no chart
2. Please ALWAYS give steps to reproduce

3. I've tested with enterprise example (see docs\files_examples\ folder)
   and it work
(0004573)
amitkhullar (reporter)
2008-11-11 17:33

Even I tried with the same data enterprise example using the 1.8 RC 1 but its not working. I have deployed a fresh build and again tested it but still blank page as in attachment.

Amit
(0004574)
fman (administrator)
2008-11-11 18:44

without detailed steps to reproduce I will close this issue
(0004579)
amkhullar (reporter)
2008-11-11 19:13

The steps are :

1: Create a new Project
2: Import new test cases under that project. used the enterprise data here.
3: Assign those test cases to a testplan.
4: Assign the test cases for execution to the user.
5: Log with the user and execute the test cases against a build.
6: see the test report for that build which does displays the Pass/ Fail results.
7: Run the Charts it displays empty page as attached.
(0004607)
fman (administrator)
2008-11-13 22:34

please use attached fix and let us know result
(0004620)
amitkhullar (reporter)
2008-11-14 04:59

not working still empty page as earlier.
(0004621)
amitkhullar (reporter)
2008-11-14 12:20

These 2 errors were logged in the events log this time when fix was applied:

Timestamp 14/11/2008 04:18:27
Source GUI
Description E_WARNING Invalid argument supplied for foreach() - in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\testlink\lib\results\keywordBarChart.php - Line 82


Timestamp 14/11/2008 04:18:27
Source GUI
Description E_NOTICE Undefined property: stdClass::$chart_data - in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\testlink\lib\results\keywordBarChart.php - Line 82
Session information
(0004622)
fman (administrator)
2008-11-14 15:57

Very strange, but anyway I will retest and give you some answer next week.

Please sendme a zip file with a dump of DB you are using to test to:

francisco.mancardi@gmail.com

to test with same data.

regards
(0004647)
fman (administrator)
2008-11-19 15:41

unable to reproduce see what user said on 1861, and retest
(0004649)
amitkhullar (reporter)
2008-11-19 17:30

I tried it again still i cudnt make it working. Same thing a blank page with titles and place holders as in attachment.

Could you send me a code snippet with echo inserts for different query / variables etc which might be causing the issue.

Thanks
Amit
(0004650)
amitkhullar (reporter)
2008-11-19 18:52

found the issue... after lot of debugging...


The new pchart plugin requires a change in php.ini

extension=php_gd2.dll

This DLL needs to be enabled for the graphs to be rendered. Probably you should add this in the Release Notes / Installation Notes also..

Regards

Amit
(0004651)
amitkhullar (reporter)
2008-11-19 18:57

Anyways thanks for all the help.

Amit
(0004660)
schlundus (reporter)
2008-11-20 03:59

Config check for php_gd2.dll extension added

- Issue History
Date Modified Username Field Change
2008-11-10 14:36 amitkhullar New Issue
2008-11-10 14:36 amitkhullar File Added: charts.JPG
2008-11-10 14:37 amitkhullar Note Added: 0004559
2008-11-10 19:09 fman Status new => assigned
2008-11-10 19:09 fman Assigned To => fman
2008-11-10 19:34 fman Note Added: 0004564
2008-11-11 17:33 amitkhullar Note Added: 0004573
2008-11-11 18:44 fman Note Added: 0004574
2008-11-11 19:13 amkhullar Note Added: 0004579
2008-11-11 23:05 fman Relationship added related to 0001851
2008-11-13 22:33 fman File Added: fix-1848.zip
2008-11-13 22:34 fman Note Added: 0004607
2008-11-13 22:34 fman Status assigned => feedback
2008-11-14 04:59 amitkhullar Note Added: 0004620
2008-11-14 12:20 amitkhullar Note Added: 0004621
2008-11-14 15:57 fman Note Added: 0004622
2008-11-19 15:41 fman Relationship added related to 0001861
2008-11-19 15:41 fman Note Added: 0004647
2008-11-19 17:30 amitkhullar Note Added: 0004649
2008-11-19 18:52 amitkhullar Note Added: 0004650
2008-11-19 18:57 amitkhullar Note Added: 0004651
2008-11-20 03:59 schlundus Status feedback => resolved
2008-11-20 03:59 schlundus Fixed in Version => next development 1.8 RC 2
2008-11-20 03:59 schlundus Resolution open => fixed
2008-11-20 03:59 schlundus Note Added: 0004660
2009-01-20 05:19 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker