Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001820TestLinkReportspublic2008-10-28 02:572009-05-11 15:55
Reporteramitkhullar 
Assigned Toamitkhullar 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 Beta 3 
Fixed in Version1.8.2 
Summary0001820: Report required for identifying the Test Case Assigned to users for a particular build and there status
DescriptionCan there be a report which displays the Test Cases ideintified to all the users for a particular build or may be even release level ( paramterised input) and then the status of each of the test case against it.

Currently no report exists which shows both the data , the General Query Report only displays blanks against test cases if the execution has not been done, once the execution is done it displays the Asignee.

Amit
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon resultsByStatus.tpl [^] (1,276 bytes) 2008-11-10 19:52
? file icon results.class.php [^] (50,125 bytes) 2008-11-10 20:00
? file icon resultsByStatus.php [^] (7,025 bytes) 2008-11-10 20:00

- Relationships
duplicate of 0002374closedamitkhullar Show Assigned User in the Not Run Test Cases Report 

-  Notes
(0004566)
amitkhullar (reporter)
2008-11-10 19:59

I have tried to figure a temporary solution for this , updated the report Not Run Test Cases:

Updates in the files

1 : \gui\templates\results\resultsByStatus.tpl
2 : \lib\results\resultsByStatus.php ( I feel the logic I have used can be improved to get the User_id field as AssignedTo : don't have much programming knowldege)
3 : \lib\functions\results.class.php
4 : Update Strings.txt with $TLS_Assigned_To = "Assigned To";

Probably u can merge them in the main head.

Amit
(0006517)
fman (administrator)
2009-04-22 14:58

@Amitk: this code is on CVS ?? has been refactored ??

- Issue History
Date Modified Username Field Change
2008-10-28 02:57 amitkhullar New Issue
2008-11-03 18:22 amitkhullar Note Added: 0004495
2008-11-10 19:28 amitkhullar Note Deleted: 0004495
2008-11-10 19:52 amitkhullar File Added: resultsByStatus.tpl
2008-11-10 19:59 amitkhullar Note Added: 0004566
2008-11-10 20:00 amitkhullar File Added: results.class.php
2008-11-10 20:00 amitkhullar File Added: resultsByStatus.php
2008-11-13 00:31 schlundus Severity major => feature request
2009-04-22 10:52 amitkhullar Relationship added duplicate of 0002374
2009-04-22 10:52 amitkhullar Status new => resolved
2009-04-22 10:52 amitkhullar Fixed in Version => 1.8.2 (bug fixing)
2009-04-22 10:52 amitkhullar Resolution open => fixed
2009-04-22 10:52 amitkhullar Assigned To => amitkhullar
2009-04-22 14:58 fman Note Added: 0006517
2009-05-11 15:55 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker