Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001794TestLinkTest Plan (builds, milestones, test assign)public2008-10-13 16:352010-05-03 00:24
Reporteramitkhullar 
Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 Beta 3 
Fixed in Version1.9 Beta 4 
Summary0001794: The Test Plan assign page doesn't return correct results when Assigned to Parameter is used.
DescriptionThe Test Plan assign page doesn't return correct results when Assigned to Parameter is used. I have run the query with AND filter on a Keyword as well as Assigned to Field. It returns the 3 issues that are assigned to me (Amit) in the Tree bar but the Test Case Assignment page carries all the issue which are in the Test Suite even though they are not assigned to me. Please see the attachment for more clarification.

Regards
Amit
Additional InformationCreate some new test cases
Goto PAge Assign Test Cases to TEst Plan
Assign some (not All) of the newly created test cases to some user
Run the filter on the Assigned to field with the user whom you have assigned the test cases.

The Tree filters the test cases list to the ones that are assigned to the user
but as soon as you click on the Suite above the assigned test cases the result set displayed on right side displays all the test cases that have either been assigned to you or some other user or nobody

Whereas it should only display those test cases that were assigned to the user you specified on the filter.

hope this clarifies this issue.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon tp assign query.JPG [^] (113,232 bytes) 2008-10-13 16:35

- Relationships

-  Notes
(0004370)
fman (administrator)
2008-10-15 00:03

Step 1 - get last CVS code and retest
Step 2 - please give detailed steps to reproduce
(0004435)
fman (administrator)
2008-10-23 15:39

any news? I need to know if i can close it
(0004436)
amitkhullar (reporter)
2008-10-23 16:08

Choose the Test Plan and select a user in Assigned to Field, then select the AND condition.
Run the query, now see the tree view:-
it has only those test plans which are assigned to me. THis is correct.
Now see the right hand page for the sametest suite it displays all the test cases in the test plan rather than the only one which are assigned to me. It should not be that way.

I have tested this on the latest code as well.

Amit
(0009790)
amitkhullar (reporter)
2010-04-20 13:25

I just noticed This issue still exists in 1.8.5
(0009793)
fman (administrator)
2010-04-20 15:15

check on 1.9, because I do not plan to make new releases for 1.8x
(0009796)
amitkhullar (reporter)
2010-04-20 15:55

ok, but if possible can you please provide the fix for this issue on 1.8.5

This seems to be fixed on 1.9
(0009797)
fman (administrator)
2010-04-20 17:24

>> ok, but if possible can you please provide the fix for this issue on 1.8.5
as stated before, i do not plan to do a new release 1.8.6 because have not enough time, and we are near a new release.
You can fix this is you have time.

- Issue History
Date Modified Username Field Change
2008-10-13 16:35 amitkhullar New Issue
2008-10-13 16:35 amitkhullar File Added: tp assign query.JPG
2008-10-15 00:03 fman Note Added: 0004370
2008-10-15 00:03 fman Status new => feedback
2008-10-23 15:39 fman Note Added: 0004435
2008-10-23 16:08 amitkhullar Note Added: 0004436
2008-11-01 01:12 schlundus Status feedback => assigned
2008-11-01 01:12 schlundus Assigned To => schlundus
2008-11-01 03:15 schlundus Status assigned => resolved
2008-11-01 03:15 schlundus Fixed in Version => next development 1.8 RC 1
2008-11-01 03:15 schlundus Resolution open => fixed
2008-12-08 20:03 mhavlat Status resolved => closed
2010-04-20 13:25 amitkhullar Assigned To schlundus =>
2010-04-20 13:25 amitkhullar Note Added: 0009790
2010-04-20 13:25 amitkhullar Status closed => assigned
2010-04-20 13:25 amitkhullar Resolution fixed => reopened
2010-04-20 13:29 amitkhullar Additional Information Updated
2010-04-20 15:15 fman Note Added: 0009793
2010-04-20 15:55 amitkhullar Note Added: 0009796
2010-04-20 17:24 fman Note Added: 0009797
2010-04-20 17:24 fman Status assigned => new
2010-05-03 00:24 fman Status new => closed
2010-05-03 00:24 fman Resolution reopened => fixed
2010-05-03 00:24 fman Fixed in Version 1.8 RC 1 => 1.9 Beta 4



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker