Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001728TestLinkRequirement Managementpublic2008-09-22 02:122008-12-08 20:03
Reporterschlundus 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.8 RC 1 
Summary0001728: SQL Error when clicking on "Create Testcases" on a ReqSpec which has no requiremenrs
DescriptionSQL Error when clicking on "Create Testcases" on a ReqSpec which has no requiremenrs

Output
ERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 - SELECT *, '' AS author, '' AS modifier FROM req_specs WHERE id =

THE MESSAGE :: SQL [11] executed [took 0.0032 secs][all took 0.1134 secs]: SELECT *, '' AS author, '' AS modifier FROM req_specs WHERE id = Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
ERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY NH.node_order,title,req_doc_id' at line 1 - SELECT requirements.*, NH.node_order FROM requirements requirements, nodes_hierarchy NH WHERE requirements.id=NH.id AND srs_id= ORDER BY NH.node_order,title,req_doc_id

THE MESSAGE :: SQL [12] executed [took 0.0038 secs][all took 0.1204 secs]: SELECT requirements.*, NH.node_order FROM requirements requirements, nodes_hierarchy NH WHERE requirements.id=NH.id AND srs_id= ORDER BY NH.node_order,title,req_doc_id Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY NH.node_order,title,req_doc_id' at line 1
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon b1.png [^] (18,999 bytes) 2008-09-22 15:51


png file icon b2.png [^] (8,953 bytes) 2008-09-22 15:52


png file icon no_requirements.png [^] (15,202 bytes) 2008-09-24 19:03

- Relationships

-  Notes
(0004122)
fman (administrator)
2008-09-22 15:51

Please add details.
I have done following test

1. last CVS fresh install
2. create test project 'Entreprise Space Ship'
3. import sample file 'enterprise_all_testsuites2.xml'
4. Create Requirement Spec 'Deep Space 9'
5. Update tree
6. click on tree element 'Deep Space 9'
7. On left frame click on buttom 'Create Test Cases' (see attached image)
8. Got no error see attached image
(0004125)
schlundus (reporter)
2008-09-22 19:03

Ah, finally i've found the error:

Select reqSpec
press Reorder requirements
press Save
Wait until tree is reloaded
Press Create Testcases => error

Because after saving the req_spec_id is lost, although the right content is shown
(0004127)
fman (administrator)
2008-09-23 13:57

ok I will give a look
(0004138)
fman (administrator)
2008-09-24 19:02
edited on: 2008-09-24 19:02

I've fixed it, but today I'm not able to commit (no CVS access)

I've made also a minor change:
if Req Spec has 0 requirements, some buttons will not be displayed (see attached image no_requirements.png)


- Issue History
Date Modified Username Field Change
2008-09-22 02:12 schlundus New Issue
2008-09-22 15:28 fman Status new => assigned
2008-09-22 15:28 fman Assigned To => fman
2008-09-22 15:51 fman Note Added: 0004122
2008-09-22 15:51 fman File Added: b1.png
2008-09-22 15:52 fman File Added: b2.png
2008-09-22 19:03 schlundus Status closed => feedback
2008-09-22 19:03 schlundus Resolution unable to reproduce => reopened
2008-09-22 19:03 schlundus Note Added: 0004125
2008-09-22 23:24 schlundus Note Added: 0004124
2008-09-22 23:24 schlundus Priority normal => low
2008-09-22 23:24 schlundus Resolution open => unable to reproduce
2008-09-22 23:24 schlundus Status assigned => closed
2008-09-23 01:16 schlundus Note Deleted: 0004124
2008-09-23 13:57 fman Note Added: 0004127
2008-09-24 19:02 fman Note Added: 0004138
2008-09-24 19:02 fman Note Edited: 0004138
2008-09-24 19:03 fman File Added: no_requirements.png
2008-09-25 17:36 fman Status feedback => resolved
2008-09-25 17:36 fman Fixed in Version => next development 1.8 RC 1
2008-09-25 17:36 fman Resolution reopened => fixed
2008-12-08 20:03 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker