Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001725TestLinkUser Interface Generalpublic2008-09-20 19:402008-12-08 20:03
Reporterschlundus 
Assigned Toschlundus 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.8 RC 1 
Summary0001725: Special chars like ' in ProjectNames are not correctly escape when using EXTJS-Tree
DescriptionSpecial chars like ' in ProjectNames are not correctly escape when using EXTJS-Tree

Tree doesn't showup, JS-Error shown
Steps To ReproduceCreate a Testproject named like a'b
Create a Testproject named like <h1>Hello</h1>
Additional InformationRaised priority because also HTML Code is not properly escape

more problematic templates:

printdocOptions.tpl
reqSpecListTree.tpl
planAddTCNavigator.tpl
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0004114)
schlundus (reporter)
2008-09-20 20:11

All nodes are not escaped -> fixed this too

- Issue History
Date Modified Username Field Change
2008-09-20 19:40 schlundus New Issue
2008-09-20 19:40 schlundus Status new => assigned
2008-09-20 19:40 schlundus Assigned To => schlundus
2008-09-20 19:40 schlundus Issue generated from: 0001721
2008-09-20 20:11 schlundus Note Added: 0004114
2008-09-21 01:49 schlundus Status assigned => resolved
2008-09-21 01:49 schlundus Fixed in Version => next development 1.8 RC 1
2008-09-21 01:49 schlundus Resolution open => fixed
2008-12-08 20:03 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker