Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001720TestLinkUser Interface Generalpublic2008-09-20 01:152008-12-08 20:03
ReporterVyacheslav 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 Beta 3 
Fixed in Version1.8 RC 1 
Summary0001720: "Bulk user assignment" - the button for feature "check all" is not recognizable as a button
Description"The GUI is misleading in the feature", but, if to be more specific, I would say - The button for feature "check all" is not recognizable as a button.
Additional InformationSteps to reproduce:
1. Loging as admin
2. Create Project, Test Plan, Test Suite, Test Case and User
3. Click link "Assign Test Case execution"
4. Click link Project
5. Double click link Test Suite
6. Click link Test Case
7. Select "user" from "Bulk user assignment" dropdown menu
8. Click Button "Do" - nothing changed in "Assigned to" text box.
9. Select "admin" from "Assigned to" dropdown menu
10. Click Button "Do" - now "admin" in "Assigned to" text box is changed to "user".
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox
PHP Version5.2.6
TestCaseID
QA Team - Task Workflow Status
Attached Filespdf file icon tl-exec-bulk_assign.pdf [^] (183,866 bytes) 2008-10-06 19:25

- Relationships
parent of 0001426closedfman "bulk user assignment" on all underlying testsuites 
parent of 0001764closedfman assign all the test cases to a user in one go. 
child of 0001765closedfman Bulk Assignment for Assigning Test Case Execution 

-  Notes
(0004142)
schlundus (reporter)
2008-09-25 00:15

did you see the checkboxes on the left (-:
(0004144)
Vyacheslav (reporter)
2008-09-25 11:27
edited on: 2008-09-25 11:30

Yes, I did, but what I did not see - possibility to apply the same label, which I selected from "Bulk user assignment" dropdown menu, to all test cases, so I decided that if we need to do this, we have to use "Bulk user assignment" without any additional checking and, if we need to make some selection, we have to use check box of appropriate test case. I have checked manual and could not find any information about this. Only today, just by chance, I noted that exists feature "check all".
I cannot call it "button", because it is absolutely flat. If it is a button - it has to be relief to be recognized as a button, or it has to be a check box - to be more visible.

(0004193)
schlundus (reporter)
2008-09-27 14:44

OK, that's a good point.

so please tell us, what exactly is the bug now

a) The functionality bulk assignment is not working
b) The GUI is misleading in the feature

Also please update the bug according to a) or b) so we all know what the problem is and what we have to do...
(0004194)
Vyacheslav (reporter)
2008-09-28 08:47
edited on: 2008-09-28 08:54

Yes, we can say:"The GUI is misleading in the feature", but, if to be more specific, I would say - The button for feature "check all" is not recognizable as a button.
What do mean "update the bug" - report new issue?

(0004246)
fman (administrator)
2008-10-04 00:09
edited on: 2008-10-04 00:14

Vyacheslav:
check all is not a button is an clickable image , and same concept has been used on other parts of TL.
And adding some label on it will destroy layout.
I've seen this kind of interface multiple time on other apps.

Anyway we can this how to improve interface.
Till now is firts issue rised for this feature, than can means that:
- nobody has never used or undesrtood it
- or other users have understood how this work, or have figured how it works

may be a little help text on page will help

regards

Francisco

(0004270)
fman (administrator)
2008-10-06 19:25

Code has been refactored.
please get last code from CVS, and read attached PDF
(0004306)
fman (administrator)
2008-10-07 19:41

@Vyacheslav:
any feedback?
(0004316)
Vyacheslav (reporter)
2008-10-08 00:03

I am sorry about delay, but I use SVN and do not know how to check CVS.
(0004318)
fman (administrator)
2008-10-08 00:05

you can use last CVS code present on nightly tarballs:

http://testlink.org/cvs_tarballs/index.php?dir=head/ [^]
(0004322)
fman (administrator)
2008-10-08 00:26

ATTENTION: do not use tarball, get code from CVS

thanks
(0004326)
Vyacheslav (reporter)
2008-10-08 00:45

Could you upgrade ZIP file?

Thanks
(0004335)
Vyacheslav (reporter)
2008-10-09 05:50

I have checked the attached PDF file - now it is perfect!
I would have had no questions, if it had been so before.
Good job - thank you.

Vyacheslav
(0004340)
fman (administrator)
2008-10-09 14:49

Please get code from:

http://testlink.org/cvs_tarballs/index.php?dir=head/&file=SNAPSHOT-HEAD-2008-10-08.tar.bz2 [^]

- Issue History
Date Modified Username Field Change
2008-09-20 01:15 Vyacheslav New Issue
2008-09-20 01:15 Vyacheslav Browser => Firefox
2008-09-20 01:15 Vyacheslav PHP Version => 5.2.6
2008-09-25 00:15 schlundus Note Added: 0004142
2008-09-25 11:27 Vyacheslav Note Added: 0004144
2008-09-25 11:29 Vyacheslav Note Edited: 0004144
2008-09-25 11:30 Vyacheslav Note Edited: 0004144
2008-09-27 14:44 schlundus Note Added: 0004193
2008-09-28 08:47 Vyacheslav Note Added: 0004194
2008-09-28 08:54 Vyacheslav Note Edited: 0004194
2008-09-28 08:54 Vyacheslav Note Edited: 0004194
2008-09-30 01:37 schlundus Category Test Plan (builds, milestones, test assign) => User Interface General
2008-09-30 01:37 schlundus Summary Function "Bulk user assignment" does not work in fresh open window. => "Bulk user assignment" - the button for feature "check all" is not recognizable as a button
2008-09-30 01:37 schlundus Description Updated
2008-10-04 00:09 fman Note Added: 0004246
2008-10-04 00:14 fman Note Edited: 0004246
2008-10-06 19:25 fman Note Added: 0004270
2008-10-06 19:25 fman File Added: tl-exec-bulk_assign.pdf
2008-10-06 22:15 fman Status new => feedback
2008-10-06 22:18 fman Relationship added child of 0001765
2008-10-06 22:18 fman Relationship added parent of 0001426
2008-10-06 22:19 fman Status feedback => assigned
2008-10-06 22:19 fman Assigned To => fman
2008-10-06 22:20 fman Relationship added parent of 0001764
2008-10-07 19:41 fman Note Added: 0004306
2008-10-07 19:41 fman Status assigned => feedback
2008-10-08 00:03 Vyacheslav Note Added: 0004316
2008-10-08 00:05 fman Note Added: 0004318
2008-10-08 00:26 fman Note Added: 0004322
2008-10-08 00:45 Vyacheslav Note Added: 0004326
2008-10-09 05:50 Vyacheslav Note Added: 0004335
2008-10-09 14:49 fman Note Added: 0004340
2008-10-10 17:03 fman Status feedback => resolved
2008-10-10 17:03 fman Fixed in Version => next development 1.8 RC 1
2008-10-10 17:03 fman Resolution open => fixed
2008-12-08 20:03 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker