Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001703TestLinkRequirement Managementpublic2008-09-09 21:362013-09-09 20:59
Reportersackermann 
Assigned ToJulian 
PrioritylowSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 Beta 2 
Fixed in Version1.9.1 (bug fixing) 
Summary0001703: Ability to set Priorities to requirements
DescriptionIt would be very valuable if we had the ability to set priorities to the requirements, like it is done for the test cases.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserall
PHP VersionN/A
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0004059)
mhavlat (reporter)
2008-09-09 22:41

Such feature is currently out of the development team scope. We are looking for a conributor. Do you interest?
(0004060)
sackermann (reporter)
2008-09-09 22:44

I guess that you miss some resources to implement such feature, however I suggest that the request is kept for a further major release.
Regarding my own contribution, I am a very poor developper, so my help would not be very valuable for such action.
(0004064)
fman (administrator)
2008-09-10 01:51

OK no dev help, but what about a detailed analisys of what you would like to have ?
(0004069)
fman (administrator)
2008-09-10 12:32

on 1.8 you can use Custom fields on requirements.
give a look and give us some feedback please
(0004073)
sackermann (reporter)
2008-09-10 14:39

I did not know about this feature being activated for requirements in 1.8. It seems to fulfil needs I was pointing out.
Now the remaining problem is that custom fields in requirements are not exported while using export feature.

Regarding requirement view, it was also very interesting to display requirements as table. Actually, it would be nice to be able to toggle both views (table or tree), but this is a totally different request.
(0004074)
fman (administrator)
2008-09-10 14:54

>> I did not know about this feature being activated for requirements in 1.8.
>> It seems to fulfil needs I was pointing out.
Advice: we have lot of troubles updating documentation (Just For the records: mhavlat is using 99% of his time to do this work instead of developing :( )

>> Now the remaining problem is that custom fields in requirements
>> are not exported while using export feature.
Issue remain because today if I'm not wrong we do not export testcase priorities.
Export/import feature always are delayed, because we work first on online features.

>>Regarding requirement view, it was also very interesting to display >>requirements as table. Actually, it would be nice to be able to toggle both >>views (table or tree), but this is a totally different request.
differente request needs a different mantis issue.
report it but with some kind of analisys / screen prototypes.
Attention: 1.9 will support N depth requirement tree
(0006810)
mhavlat (reporter)
2009-05-10 14:20

Accepted with low priority.

Suggested design:
REQ1: Users can define priority HIGH, MEDIUM and LOW for requirements. MEDIUM is configurable default value. DB field is number with default value 2.
REQ2: The feature is optional a must be enabled on Test project level.
REQ3: User can filter requirements in tree menu.
REQ4: Priority is visible in generated SRS document if enabled for the project.
(0006825)
mhavlat (reporter)
2009-05-12 11:53

REQ 2 explanation: One of our basic requirements is simplicity. I.e. users should see just used functionality. Medium size company with more projects should allow it only for particular teams.
(0014663)
Julian (reporter)
2011-04-15 16:57

REQ1: Users can define priority HIGH, MEDIUM and LOW for requirements. MEDIUM is configurable default value. DB field is number with default value 2.
-> can be done with costom field
REQ2: The feature is optional a must be enabled on Test project level.
-> custom fields have to be assigned on project level
REQ3: User can filter requirements in tree menu.
-> filtering by custom fields works for requirements
REQ4: Priority is visible in generated SRS document if enabled for the project.
-> custom fields are printed in requirement specification document

- Issue History
Date Modified Username Field Change
2008-09-09 21:36 sackermann New Issue
2008-09-09 21:36 sackermann Browser => all
2008-09-09 21:36 sackermann PHP Version => N/A
2008-09-09 22:41 mhavlat Note Added: 0004059
2008-09-09 22:41 mhavlat Status new => feedback
2008-09-09 22:44 sackermann Note Added: 0004060
2008-09-10 01:51 fman Note Added: 0004064
2008-09-10 12:32 fman Note Added: 0004069
2008-09-10 14:39 sackermann Note Added: 0004073
2008-09-10 14:54 fman Note Added: 0004074
2009-03-09 20:58 mhavlat Relationship added related to 0002095
2009-03-09 21:11 mhavlat Relationship deleted related to 0002095
2009-05-10 14:20 mhavlat Note Added: 0006810
2009-05-10 14:20 mhavlat Priority normal => low
2009-05-10 14:20 mhavlat Status feedback => acknowledged
2009-05-12 11:53 mhavlat Note Added: 0006825
2011-04-15 16:57 Julian Note Added: 0014663
2011-04-15 16:57 Julian Status acknowledged => resolved
2011-04-15 16:57 Julian Fixed in Version => 1.9.1 (bug fixing)
2011-04-15 16:57 Julian Resolution open => fixed
2011-04-15 16:57 Julian Assigned To => Julian
2013-09-09 20:59 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker