Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001697TestLinkReportspublic2008-09-03 23:032009-01-20 05:19
Reporternorrelld 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.4 
Fixed in Version1.8 RC 2 
Summary0001697: Results generating blank reports, Charts timing out
Descriptionwe have installed TestLink 1.7.4, created a test project with test cases, test plans and builds but we do not get reports for any of the test plans that have been executed.

When we select any results report the right hand panel returns blank, selecting charts shows the Flash objects with 'Loading <lib/results/overallPieChart.php> timed out (-1)'.

Any ideas how to resolve this problem?
We are trialing TestLink and like moment, everything looks good apart from the reporting.

Thanks
Duncan
Additional InformationThis is a default install with a minor config change to linkup to LDAP
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0001425closedfman Results > Charts shows error "Loading <lib/results/overallPieChart.php) timed out. (-1) 

-  Notes
(0004088)
mhavlat (reporter)
2008-09-17 16:31

Is not 1425 your case too?
(0004089)
norrelld (reporter)
2008-09-17 16:42

this is not my case, but we are hving these issues as well. i will try the suggestions made on the related issue to see if this resolves our problems
Thanks
(0004092)
norrelld (reporter)
2008-09-17 21:32

we have tried the following and if anything the charts seems to be worse as it's not even loading the flash charts

· Increase 'max_execution_time' in php.ini from 30 to 60

· Change $charts_swf= $pathToCharts . "/charts.swf"; to $charts_swf= $pathToCharts . "/charts.swf?timeout=120"; in lib/results/charts.php

·Add the following to lib/results/charts.php

o header("Cache-Control: cache, must-revalidate");

o header("Pragma: public");

We did try again reverting the last item as we dont use TestLink over https.

any further suggestions would be much appreciated

- Issue History
Date Modified Username Field Change
2008-09-03 23:03 norrelld New Issue
2008-09-17 16:30 mhavlat Relationship added related to 0001425
2008-09-17 16:31 mhavlat Note Added: 0004088
2008-09-17 16:42 norrelld Note Added: 0004089
2008-09-17 21:32 norrelld Note Added: 0004092
2008-11-13 22:38 fman Status new => resolved
2008-11-13 22:38 fman Fixed in Version => next development 1.8 RC 2
2008-11-13 22:38 fman Resolution open => fixed
2008-11-13 22:38 fman Assigned To => fman
2009-01-20 05:19 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker