Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001681TestLinkTest Executepublic2008-08-21 19:282009-02-13 18:59
Reporternarsu 
Assigned Tomhavlat 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.4 
Fixed in Version1.7.5 
Summary0001681: Blocked status as default state for result
DescriptionHi!

This could be duplicate, but anyway!

1. If I execute test case and I give it verdict "PASSED"
2. I do refrsh for testcase tree and open same case again...
3. I can see that Status is "PASSED" with Green background, but radio button is in BLOCKED state?

I think radio button should be checked as latest verdict status ?
Additional InformationI have been testing stable 1.7.4 and latest 1.7.5 version 21-8-2008

Centos 5.0
MySQL 5.0.45
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0003992)
narsu (reporter)
2008-08-21 19:34

I understand current implementation, but in several cases there could be much easier to set default state to NOT-RUN? Like in older versions of Testlink 1.6.3?

BLOCKED can have several reasons like (not implemented, broken implementation, force major)

What do you think?
(0003993)
fman (administrator)
2008-08-21 20:52

1. I think radio button should be checked as latest verdict status ?
No, that was how 1.6 and older versions work, because TL save always LAST execution.
With new TL versions is not this way anymor.

2. Issue with Not run:
when you choose not run, no information is written to db. (always has been this way)
You can re-enable not run, acting on configuration files.
Let me know if you need help.
(0003996)
narsu (reporter)
2008-08-22 12:26

Thanks!

Ps. Why "NOT RUN" is not default feature ?
(0004015)
mhavlat (reporter)
2008-08-27 04:33

I enabled "NOT RUN" status by default. It's also default settings for execution now.
Fixed on both 1.7 branch and HEAD.

- Issue History
Date Modified Username Field Change
2008-08-21 19:28 narsu New Issue
2008-08-21 19:34 narsu Note Added: 0003992
2008-08-21 20:52 fman Note Added: 0003993
2008-08-22 12:26 narsu Note Added: 0003996
2008-08-27 04:33 mhavlat Note Added: 0004015
2008-08-27 04:33 mhavlat Status new => assigned
2008-08-27 04:33 mhavlat Assigned To => mhavlat
2008-08-27 04:34 mhavlat Status assigned => resolved
2008-08-27 04:34 mhavlat Fixed in Version => next hot-fix (1.7.5)
2008-08-27 04:34 mhavlat Resolution open => fixed
2009-02-13 18:59 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker