Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001502TestLinkDatabase MySQLpublic2008-04-23 15:482008-12-08 20:04
Reporterfkueppers 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.4 
Fixed in Version1.8 Beta 3 
Summary0001502: Test cases, Keywords and Test plans missing after migration from 1.6.3 to 1.7.4
DescriptionMigration was done as follows:
- MySQL (v4.1.11) dump from old 1.6.0
- "import" to TestLink 1.6.3 -> all seems fine (Test Cases, Keywords and Testplans OK)
- setup TL 1.7.4 -> new installation
- migration from 1.6.3 to 1.7.4
-> no errors where shown, I'm able to login with the migrated users, all products and Test suites shown (TL 1.6 : Components and Categories) but no Test cases, keywords and Test plans

The old database had charset latin1. I made the migration with the latin1 db and also after converting the db dump to utf8 -> same result.

I've checked the migrated database and found the lost Test cases in table "tcversions". I also found the Test Case Titles in table "nodes_hierarchy" but the parent_id shows always "0" for Test cases. The "parent_id"/"id" of Test Suites seems to be referenced correctly

Any tables that seems to be related with keywords (keywords, object_keywords, testcase_keywords)or Testplans (testplans, testplan_tcversions) are empty
Additional InformationDebian Etch
TestLink 1.7.4
MySQL 5.0.32
PHP 5.2.0
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 2.0.0.14
PHP Version5.2.0-8+etch10 (Debian)
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0003491)
fman (administrator)
2008-04-23 21:29

only way to help is having a dump of your 1.6.x db
(0003494)
fkueppers (reporter)
2008-04-24 15:33

RESOLVED

Problem was caused by global PHP settings in php.ini:

max_execution_time = 30 ; Maximum execution time of each script, in seconds
max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
memory_limit = 16M ; Maximum amount of memory a script may consume (16MB)

was to less/small for the migration

The following works for me to migrate about 1600 Test cases:
max_execution_time = 120
max_input_time = 120
memory_limit = 64M

I don't know if this are Debian specific or PHP standard settings.

Nevertheless a hint in the Installation guide would be helpful.
(0003495)
fman (administrator)
2008-04-24 16:07

Thanks a lot.
I will add some note on installer/migrator

Regards

Francisco

- Issue History
Date Modified Username Field Change
2008-04-23 15:48 fkueppers New Issue
2008-04-23 15:48 fkueppers Browser => Firefox 2.0.0.14
2008-04-23 15:48 fkueppers PHP Version => 5.2.0-8+etch10 (Debian)
2008-04-23 21:29 fman Note Added: 0003491
2008-04-24 15:33 fkueppers Note Added: 0003494
2008-04-24 16:07 fman Note Added: 0003495
2008-04-24 16:07 fman Status new => assigned
2008-04-24 16:07 fman Assigned To => fman
2008-11-09 01:34 fman Status assigned => resolved
2008-11-09 01:34 fman Fixed in Version => 1.8 Beta 3
2008-11-09 01:34 fman Resolution open => fixed
2008-12-08 20:04 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker