Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001490TestLinkTest Executepublic2008-04-17 20:562009-04-05 00:46
Reportertalame 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 Beta 1 
Fixed in Version1.8 RC 4 
Summary0001490: EstimatedExecuteTime and TesterExecuteTime for performance management
DescriptionSuggestion:
It would be nice for performance purpose the Test Case include the Estimated time it should take a user to execute a test case. This field should be enabled on the Created Test case and the last Tester Execute time as read-only.
On Test case development the field spec shall be:
- EstimatedExecuteTime (minutes) enable, modification recorded by who
- TesterExecuteTime (minutes) read-only, associate user (Change history)

Test Execution:
The Test Execute user shall be able to view the estimated execute time defined by senior testers or analyst and enter the actual time it took him/her to execute the test case.
Field Spec - EstimatedExecuteTime (minutes) read-only
           - TesterExecuteTime (minutes) enabled. Value is recorded for every test build.

Reporting/Metrics:
The tester execute time instances should be recorded for metric and perfomance measurement so that seniro leader may revise the Estimated Execute Time as deemed necessary.

Conclusion:
EstimatedExecuteTime, Modifiedby <loggedinuser>, DateModified <loggedinuser>
TesterExecuteTime, Modifiedby <loggedinuser>, DateModified <loggedinuser>

Reporting Query:
Would be nice a graphic represenation between the EstimatedExecuteTime, TesterExecuteTime between same/different builds as compared by other tester.
Additional InformationAfter July 15, I would have more time to help you out on any issues related to testing or quality improvement of testlink
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE, FireFox
PHP Version5.0
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon EstExecuteTime.JPG [^] (81,564 bytes) 2008-04-17 20:56

- Relationships
related to 0001910closedfman EstimatedExecuteTime is always calculated over the whole testplan 
parent of 0001868closedfman Ability to assign execution time for a test case 

-  Notes
(0003450)
fman (administrator)
2008-04-17 23:25

try using Custom Field
(0003470)
mhavlat (reporter)
2008-04-20 05:38

EstimatedExecuteTime could be solved by custom fields. It make sense only if there will be also some analyse page that count estimated time for particular users.

Real execution time needs to set start/end ... testers do not care in real process about such attributes. No big value for tool.

I suggest to reject.
(0003784)
fdvm (reporter)
2008-07-10 15:24

I think this is a good feature that could help in planning tasks for example and I am almost agree in using custom fields for it but this causes a big problem: if you want to store the estimated times for test suites and test plan, you have to control this manually, so any change in the estimated time for a test case makes that you have to modify manually the estimated time of the test suite and the test plan that contain it.
(0003788)
talame (reporter)
2008-07-10 18:25

Honestly, I believe the test case component should include fields with enable/disable field but not custom.

TestCase ID/Title:
Description:

Preconditions: [Important]

Test Steps Expected Result:
---------- ---------------
1.Do this 1. Got that
2.Do this 2. Got that
. .
. .
n. n.

Estimated Execute: [005] minutes (read-only in execute time)
Tester Execute Time: [010] minutes (Disabled or read-only on design time)

Post-conditions/Comments:


Test Case Completed: [Design Flag - checkbox indicating the test case design is complete or inprogress]..example missing steps or not enough info...Iterative approach, develop test cases while requirement and specification are still incomplete or being updated continuously (Project management iteration between phases and agile approach)
-------------------------------

Presently, I am using custom fields but the problem is that I would like to use the estimated execute time in my Test plan, i.e. everytime, I add a Test case to my test plan, the estimated test plan execution will increment to give the tester(s) and idea how much time will it take to execute a test case suite(s).
For example, test case 1 (5 mins) + Test case 2 (2 mins); Therefore, the total estimated execution time is 7 mins.

How this will impact the reports?
A field in report shall indicate the time it took to execute a test plan by a user for a specific build. This will help management improve the quality and identify performance issues.

Again, I am basing the above based on experience of over 8 years of QA. But, I also understand the challenges to the testlink team coding the above and ISO standards.

Thanks,
Toufic
(0003789)
fman (administrator)
2008-07-10 19:15

Dev Team really appreciate every help/comment we get from users.
We try to plan such a kind of changes but ..., I would like from you a more detailed analysis of your requirements (may be a word or open office document)
to focus better our development.

regards
(0003797)
mhavlat (reporter)
2008-07-11 16:42

Ok. I can draft a simple solutions:
Design 1:
User will use CF to set estimated time for TCs. There will be a configuration parameter:
$tlCfg->EstimatedTimeID = 0;
Zerou is default and means disabled. A user can add ID for CF field that is used the estimated time.
A new (report) page is available for a Test Plan in this case. This page will include overall estimated time and list of TCs with the time.

Real execution times should be added similar way.

Design 2:
There will be a configuration parameters:
$tlCfg->ExecutionTimeAvailability = DISABLED; (default)
$tlCfg->ExecutionTimeDefault = 1;
$tlCfg->ExecutionTimeValues = array (1=>'1 min'*, 5=> '5 min', etc.)
Add testing time combo-box to execution (and TC page) page: 1 min , 5 min, 15 min, 30 min, 1h, 2h, 4h, 1 day**, 3 days

There must be a new field to tc_version and execution tables for this parameter time. I guess that integer with minutes is appropriate type.

* localization label should be here of course
** 1 day = 8 hours

Now, you can review my proposal ... and contribute (if you hurry - the issue has low priority for us). I guess that there already are users that have implementation, but they are egoists.

PS to Toufic: Do not mess more issues into one. We will ignore your proposition here. Browse tracker and comment appropriate issues. Thanks.
(0004795)
fman (administrator)
2008-12-09 16:26

Please give a look to issues related to this, get last CVS code and gie us feedback
(0005486)
mhavlat (reporter)
2009-02-16 05:18

Reminder sent to: talame

talame, could you give us your feedback or state that you have not chance to try it. Thanks.
(0005546)
fman (administrator)
2009-02-19 15:38

No more user feedback

- Issue History
Date Modified Username Field Change
2008-04-17 20:56 talame New Issue
2008-04-17 20:56 talame File Added: EstExecuteTime.JPG
2008-04-17 20:56 talame Browser => IE, FireFox
2008-04-17 20:56 talame PHP Version => 5.0
2008-04-17 23:25 fman Note Added: 0003450
2008-04-20 05:38 mhavlat Note Added: 0003470
2008-07-10 15:24 fdvm Note Added: 0003784
2008-07-10 18:25 talame Note Added: 0003788
2008-07-10 19:15 fman Note Added: 0003789
2008-07-11 16:42 mhavlat Note Added: 0003797
2008-07-11 16:44 mhavlat Projection none => minor fix
2008-07-11 16:44 mhavlat Summary Would be nice to add a static EstimatedExecuteTime and TesterExecuteTime for performance management => EstimatedExecuteTime and TesterExecuteTime for performance management
2008-12-09 16:25 fman Relationship added related to 0001910
2008-12-09 16:26 fman Relationship added parent of 0001868
2008-12-09 16:26 fman Note Added: 0004795
2008-12-09 16:26 fman Status new => feedback
2009-02-16 05:18 mhavlat Note Added: 0005486
2009-02-19 15:38 fman Status feedback => resolved
2009-02-19 15:38 fman Fixed in Version => 1.8 RC 4
2009-02-19 15:38 fman Resolution open => fixed
2009-02-19 15:38 fman Assigned To => fman
2009-02-19 15:38 fman Note Added: 0005546
2009-04-05 00:46 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker