Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001422TestLinkAPI - XMLRPCpublic2008-03-06 17:392015-09-19 08:49
Reportertuergeist 
Assigned Tofman 
PrioritylowSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.11 (2014 Q2 - bug fixing) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0001422: Generate user API Key by admin
DescriptionIf admin creates a special API-user, he has to login as API-user to generate the API key.

IMHO it should be possible for admin to create those keys for every user.
If I'm wrong and there is such a button, this is an usability issue ;)
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0001893closedfman Admin should be able to e-mail users their API key 
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0004667)
azl (administrator)
2008-11-20 05:04

Currently users have to generate their own API keys. The admin should be able to do this for users as well as send an e-mail to users with their API key.
(0004789)
azl (administrator)
2008-12-09 06:57

Should be part of the 1.9 release.
(0004792)
fman (administrator)
2008-12-09 16:18

Why is need this feature?
see no need, explain better
(0004808)
azl (administrator)
2008-12-10 05:18

This is a similar argument to why an admin should be able to create users, change users info, and perform general admin-type tasks. The reasons we have these types of features are the same reasons we should have this feature.

This is simply a feature to allow an admin the ability to generate API keys for users rather than users always having to do it themselves.
(0004809)
azl (administrator)
2008-12-10 05:20

See no need for private view status. Changing to public.
(0004816)
mhavlat (reporter)
2008-12-10 17:41

Please, design it with respect to security. I think that Admin should not be able to see the key. Of course he could generate email that include it.
(0023163)
Mr.Bricodage (updater)
2015-04-26 15:56

linked to 0001893 that is more secure and that is the proposed solution for this bug
(0023337)
fman (administrator)
2015-05-10 15:38

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/7b33739382b6c5439d0f4d9f55f15c0926d184d4 [^]
(0023937)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2008-03-06 17:39 tuergeist New Issue
2008-11-20 05:03 azl Status new => assigned
2008-11-20 05:03 azl Assigned To => azl
2008-11-20 05:04 azl Note Added: 0004667
2008-11-20 05:06 azl Relationship added related to 0001893
2008-12-09 06:57 azl Note Added: 0004789
2008-12-09 16:18 fman Note Added: 0004792
2008-12-10 05:18 azl Note Added: 0004808
2008-12-10 05:20 azl Note Added: 0004809
2008-12-10 05:20 azl View Status private => public
2008-12-10 05:20 azl Description Updated
2008-12-10 17:41 mhavlat Note Added: 0004816
2008-12-10 17:41 mhavlat Summary CVS: API Key could not be generated for other users => Generate user API Key by admin
2012-06-15 21:32 fman Assigned To azl =>
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC
2015-04-26 15:56 Mr.Bricodage Note Added: 0023163
2015-04-26 15:57 Mr.Bricodage Relationship added child of 0007083
2015-05-10 15:37 fman QA Team - Task Workflow Status => TBD
2015-05-10 15:37 fman Product Version => 1.9.11 (2014 Q2 - bug fixing)
2015-05-10 15:37 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-05-10 15:38 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-05-10 15:38 fman Note Added: 0023337
2015-05-10 15:38 fman Status assigned => resolved
2015-05-10 15:38 fman Resolution open => fixed
2015-05-10 15:38 fman Assigned To => fman
2015-05-10 15:38 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023937
2015-09-19 08:49 fman Status resolved => closed
2016-02-29 23:34 Mr.Bricodage Relationship deleted child of 0007083



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker