Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001382TestLinkCustom fieldspublic2008-02-12 01:232009-01-20 05:19
Reporterdzko 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.3 
Fixed in Version1.8 RC 2 
Summary0001382: Custom field format
DescriptionFormally You can define Custom field format, but Custom field values anyway is kept in varchar format in DB in table 'cfield_execution_values' in field 'value' and user anyway here can insert wrong format data - as example in place of numeric values for numeric CF any combination of letters.

Of course it is not critical, but seems little bit stupid.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE6
PHP Version5
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0003247)
fman (administrator)
2008-02-12 19:22

We need to add and enable regexp control.
I've implemented CF following (and using code form ) Mantis model.

Target release: 1.8.1 or 1.9
(0003408)
seans (reporter)
2008-04-02 05:44

Yes, I agree with this bug. I'm trying to define a "Staff Time" field to allow only numeric input, but there seems to be no numeric restraint on the field as it allows any string to be entered.
(0004848)
fman (administrator)
2008-12-15 16:38

resolved with js validation

- Issue History
Date Modified Username Field Change
2008-02-12 01:23 dzko New Issue
2008-02-12 01:23 dzko Browser => IE6
2008-02-12 01:23 dzko PHP Version => 5
2008-02-12 18:54 fman Status new => assigned
2008-02-12 18:54 fman Assigned To => fman
2008-02-12 19:22 fman Note Added: 0003247
2008-04-02 05:44 seans Note Added: 0003408
2008-12-15 16:38 fman Status assigned => resolved
2008-12-15 16:38 fman Fixed in Version => 1.8 RC 2
2008-12-15 16:38 fman Resolution open => fixed
2008-12-15 16:38 fman Note Added: 0004848
2009-01-20 05:19 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker