Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001309TestLinkTest Specificationpublic2008-01-22 10:152008-11-07 19:47
Reportermroeder 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 final 
Fixed in Version1.8 Beta 2 
Summary0001309: updating test cases requires tedious steps to update test plans and assignments
DescriptionWhen you edit a test case, this generates a new version. The new version is not automatically incorporated into the test plans and assignments. After test cases have been edited, one must Home > Show test Cases Newest Versions.
Then for every new version of a test case, one must...
1. Remove the test case.
2. Add test case.
3. Assign test case execution.

Expected: In the Show test Cases Newest Versions page, every new test case should have a checkbox. There should be a button "Update Test Plans" that does all that for me.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0003025)
fman (administrator)
2008-01-23 15:34

Please do some search on mantis, this has been discussed a lot.
Every TC version assigned to a Testplan, and executed has a result.
If we upgrade TCversion we will remove result, because in TL (and this will not change) a new version is a different thing.
IF you have created a new version, for us results regarding to previous version CAN NOT be retained.

You have an option: allow edit of executed testcases, and then do not generate new versions for minor changes in test cases.

For NOT EXECUTED test cases, your request can be used, but for executed NO.

If you agree with this solution, we will update issue subject, and evaluate when implement it.

Regards
(0003052)
mroeder (reporter)
2008-01-25 03:21

Sorry, I don't understand your proposed solution.

I understand your position that changing a test case should invalidate comparisons with previous versions. In your particular application, that may be perfectly valid. But that's not the case everywhere.

The situation I'm in is that my team are overworked. We need tools to make our work more efficient. not present roadblocks everywhere. Our test suit is now basically an outline. Most test cases have just a summary, and somebody knows or has notes on the steps. We take time every day to add those details to the test database ... and I don't need that to invalidate all previous metrics or to require a tedious and error-prone process to add the test back into the plan.

Maybe a checkbox "[ ] This is a minor edit" could sidestep your strict rule. Checking that would consider the new version comparable to the old one and I'm happy. And if it's not checked, it would be strict and you're happy. :-)
(0003058)
fman (administrator)
2008-01-25 14:37

Try to explain better:

If is ok for you do not create a new version you can use a config option that allows to edit executed test cases (default is NO) (see config.inc.php)

But think your suggestion can be a good choice, warning people that old results will be assigned TO THE UPDATED version , i.e. you for this point results said yiu have never executed version N-1, after having updating testcase on testplan to version N.

is ok ?
(0003089)
mroeder (reporter)
2008-01-26 03:24

In my particular case, that's fine. And since we're pretending that the two versions of the test case are the same version, it's a FOL (Fact Of Life).
(0003095)
fman (administrator)
2008-01-28 02:05

wait till tuesday and get tarball for 1.8, you will be able to test
our last development for this feature.

please give us some feedback

- Issue History
Date Modified Username Field Change
2008-01-22 10:15 mroeder New Issue
2008-01-23 15:34 fman Note Added: 0003025
2008-01-25 03:21 mroeder Note Added: 0003052
2008-01-25 05:25 fman Status new => assigned
2008-01-25 05:25 fman Assigned To => fman
2008-01-25 14:37 fman Note Added: 0003058
2008-01-26 03:24 mroeder Note Added: 0003089
2008-01-28 02:05 fman Note Added: 0003095
2008-05-24 20:29 fman Status assigned => resolved
2008-05-24 20:29 fman Fixed in Version => 1.8 Beta 2
2008-05-24 20:29 fman Resolution open => fixed
2008-11-07 19:47 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker