Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001298TestLinkAPI - XMLRPCpublic2008-01-16 04:402008-11-07 19:47
Reportermhavlat 
Assigned Tomhavlat 
PrioritynormalSeveritymajorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.8 Beta 1 
Summary0001298: User should generate API key
DescriptionPersonal page must include a button to generate a new key.
The currently valid key is readable from the same place.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0001300closedmhavlat Users should be able to see their API key on their profile page 

-  Notes
(0002956)
azl (administrator)
2008-01-16 04:53

It is intended that only admins can generate an API key. This is currently available in CVS on the usersView.php page. I will create a different bug that allows users to view their API key on their personal profile.
(0002959)
mhavlat (reporter)
2008-01-16 05:01

I don't understand such limitation. It's more secure that a user can modify it anytime.
(0002961)
azl (administrator)
2008-01-16 05:04

This is because API keys give full permissions for running automation etc.. At least this is the way the API is currently implemented.

API keys aren't intended to be modified. They are intended to only be created once.
(0002963)
mhavlat (reporter)
2008-01-16 05:17

I understand how it works but I definitely don't understand a reason.
My view:
1. If a user can run scripts should be done consistently with other user rights. So a new right should be created. But the right to write test results could substitute it well.
2. Key is something that only the user should know (as a password).
3. I (admin) would like to don't solve that some tester need a new key. I prefer that he can manage it himself.
(0003060)
mhavlat (reporter)
2008-01-25 19:38

I made appropriate update in personal page. So user can see and generate your personal key.

- Issue History
Date Modified Username Field Change
2008-01-16 04:40 mhavlat New Issue
2008-01-16 04:53 azl Note Added: 0002956
2008-01-16 04:54 azl Relationship added related to 0001300
2008-01-16 05:01 mhavlat Note Added: 0002959
2008-01-16 05:04 azl Note Added: 0002961
2008-01-16 05:17 mhavlat Note Added: 0002963
2008-01-16 05:22 azl Status new => assigned
2008-01-16 05:22 azl Assigned To => azl
2008-01-25 19:31 mhavlat Assigned To azl => mhavlat
2008-01-25 19:38 mhavlat Status assigned => resolved
2008-01-25 19:38 mhavlat Fixed in Version => next development version (1.8 Beta1)
2008-01-25 19:38 mhavlat Resolution open => fixed
2008-01-25 19:38 mhavlat Note Added: 0003060
2008-06-03 16:48 mhavlat Fixed in Version next development version (1.8 Beta1) => 1.8 Beta 1
2008-11-07 19:47 mhavlat Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker