Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001296TestLinkAPI - XMLRPCpublic2008-01-15 19:502008-12-08 20:03
Reporterfman 
Assigned Toazl 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.8 RC 1 
Summary0001296: API table refactoring
Descriptionspecific table api_developer_keys WILL BE DROPED.
Filed api_key will be added to users table
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0002954)
mhavlat (reporter)
2008-01-16 04:29

Modified xmlrpc.php + ApiKey.php.
(0002958)
azl (administrator)
2008-01-16 04:58

There are other classes that need to be modified if this is a desired change. I don't understand why having another table is such a big deal. Having another table allows other API specific functionality to be added more easily in the future. Keeping everything in the same table will just add more work down the road.
(0002986)
schlundus (reporter)
2008-01-19 06:05

Reopened because it wasn't done in a clean way
(0002987)
mhavlat (reporter)
2008-01-20 06:09

I don't see any benefit to have no rights for API interface or doubled rights management system.
I write the idea move this key into user in the middle of November. I have not idea that Asiel has plan to enhance this table. I still don't know any problem which this refactorization brings. Maybe example helps?
I will revert changes of course if I'm wrong.

Please, let me know, which other classes miss a modification.
(0002989)
fman (administrator)
2008-01-21 19:12

I want to have real data about enhancements, not just possibilities.
I.e. if we do not have good reasons, I will remove table.
(0004411)
azl (administrator)
2008-10-17 03:26

This is no longer an issue with the latest schema changes for 1.8 and the API rights implemented. We can readdress if we decide we do need separate API rights down the road.

- Issue History
Date Modified Username Field Change
2008-01-15 19:50 fman New Issue
2008-01-15 19:50 fman Status new => assigned
2008-01-15 19:50 fman Assigned To => mhavlat
2008-01-16 04:29 mhavlat Note Added: 0002954
2008-01-16 04:29 mhavlat Status assigned => resolved
2008-01-16 04:29 mhavlat Fixed in Version => next development version (1.8 Beta1)
2008-01-16 04:29 mhavlat Resolution open => fixed
2008-01-16 04:58 azl Note Added: 0002958
2008-01-19 06:05 schlundus Note Added: 0002986
2008-01-19 06:05 schlundus Status resolved => feedback
2008-01-19 06:05 schlundus Resolution fixed => reopened
2008-01-20 06:09 mhavlat Note Added: 0002987
2008-01-21 19:12 fman Note Added: 0002989
2008-01-22 00:21 mhavlat Status feedback => assigned
2008-01-22 00:21 mhavlat Assigned To mhavlat => azl
2008-01-22 00:21 mhavlat Status assigned => feedback
2008-06-03 16:49 mhavlat Fixed in Version next development version (1.8 Beta1) => 1.8 Beta 1
2008-10-17 03:26 azl Status feedback => resolved
2008-10-17 03:26 azl Fixed in Version 1.8 Beta 1 => next development 1.8 RC 1
2008-10-17 03:26 azl Resolution reopened => fixed
2008-10-17 03:26 azl Note Added: 0004411
2008-12-08 20:03 mhavlat Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker