Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001199TestLinkUsers and Rightspublic2007-11-22 01:102015-06-30 05:34
Reporterg0llem 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version 
Fixed in Version 
Summary0001199: integration of user groups
DescriptionIntegration of user groups would be very helpful for us.

We have different user groups who are responsable for testing and i would like to have an ability to not assign a specific user as responsable for the testcase, but a user group. Of could we ned to know which specific user has executed a tc.
I thought about using keywords instead but it is not very handy for us to use keywords for many differnt aspects. (eg. prio, risk, usergroup, ...)
Is there a way to select more than one keyword to filter?

Would be nice if it is possible to configer (in config.inc.php) if a group or a user or both is selectable in a filter for execution also.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
duplicate of 0005305new Contribution - User Groups 
related to 0001081closedfman Field in user data containing one's department 
related to 0001329closedfman Create/Assign to User Groups 
related to 0006527closedfman user group feature 

-  Notes
(0002696)
fman (administrator)
2007-11-22 02:13

Use custom fields as workaround.

Please report right version not an unreleased one
(0002701)
mhavlat (reporter)
2007-11-22 19:51

I think that it could be useful to have possibility to make selection for user roles assignment.

I guess that a simple table user_group is appropriate solution. This table will not hold any rights. The purpose is just to allow select appropriate group in GUI.
Fields:
group_title STRING
user_id INTEGER

Relation to similar request by Olga added.
(0023158)
Mr.Bricodage (updater)
2015-04-26 15:47

should be closed (duplicated with 5305 that provide contribution)

- Issue History
Date Modified Username Field Change
2007-11-22 01:10 g0llem New Issue
2007-11-22 02:13 fman Note Added: 0002696
2007-11-22 19:43 mhavlat Relationship added related to 0001081
2007-11-22 19:51 mhavlat Note Added: 0002701
2007-11-22 19:51 mhavlat Severity minor => feature request
2007-11-22 19:51 mhavlat Status new => acknowledged
2007-11-22 19:51 mhavlat Product Version next version (Hot-Fix 1.7.2) =>
2008-02-11 05:55 mhavlat Relationship added related to 0001329
2014-08-21 07:49 fman Relationship added related to 0006527
2015-04-26 15:46 Mr.Bricodage Relationship added related to 0005305
2015-04-26 15:47 Mr.Bricodage Note Added: 0023158
2015-06-30 05:33 fman QA Team - Task Workflow Status => TBD
2015-06-30 05:33 fman Relationship replaced duplicate of 0005305
2015-06-30 05:33 fman Status acknowledged => resolved
2015-06-30 05:33 fman Resolution open => duplicate
2015-06-30 05:33 fman Assigned To => fman
2015-06-30 05:34 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker