Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001056TestLinkTest Executepublic2007-09-18 23:562008-11-07 19:47
Reporterrshaw 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 final 
Fixed in Version1.8 Beta 1 
Summary0001056: Test Plan - (Tree) - Showing 0 test cases to execute / Test cases are assigned to test plan.
DescriptionOn execute, the tree view is NOT displaying any test cases to execute..
(count = 0 and NO + to expand tree)

If I open go back and check (add test cases)
I can see the version currently assigned...
If I add a new one - Still nothing..

If I open my 1.7 rc3 version on the same server - everything is as expected.

TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0002179)
fman (administrator)
2007-09-19 00:10

Not enough info.
Please add detailed steps
(0002186)
hellofawedge (reporter)
2007-09-19 07:33
edited on: 2007-09-19 07:34

The test cases need to be assigned to your user that you've logged into TestLink with. Assignment to user occurs under "Test Plan Contents" off the Home page.

Until this occurs, no test cases will appear under your test project when attempting the execute the test plan.

(0002189)
fman (administrator)
2007-09-19 13:56

The problem arise due to assigner filter ?
If answer is yes , them seems not to be a bug.
(0002749)
jsm (reporter)
2007-12-03 17:19

I also was a little confused when I experienced the same behaviour first time.

IMHO it would be a good idea to change the filter presets in a way like:
if there are no testcases of the current test plan assigned to the current user, show unassigned testcases of that testplan instead.

On the other hand it might be a good idea instead of having to switch between assigned and unassigned testcases by means of the owner-filter just to have a check-box 'show unassigned testcases too' besides the scroll box. (and it should be activated by default).
(0002750)
fman (administrator)
2007-12-03 17:22

Regarding:
- IMHO it would be a good idea to change the filter presets in a way like:
- if there are no testcases of the current test plan assigned to the current user, - show unassigned testcases of that testplan instead.
No good, because then filter will be useless

- On the other hand it might be a good idea instead of having to switch between
- assigned and unassigned testcases by means of the owner-filter just to have a
- check-box 'show unassigned testcases too' besides the scroll box. (and it should - be activated by default).
May be this is right solution.
(0002848)
mhavlat (reporter)
2007-12-20 04:38

Please stay simple. I disagree to add another element if not needed.

Default value should be "not filtered" as is common in all other products. We can of course implement cookie to remember last selection of user.

- Issue History
Date Modified Username Field Change
2007-09-18 23:56 rshaw New Issue
2007-09-19 00:10 fman Note Added: 0002179
2007-09-19 07:33 hellofawedge Note Added: 0002186
2007-09-19 07:34 hellofawedge Note Edited: 0002186
2007-09-19 13:56 fman Note Added: 0002189
2007-09-19 13:56 fman Status new => feedback
2007-12-03 17:19 jsm Note Added: 0002749
2007-12-03 17:22 fman Note Added: 0002750
2007-12-19 21:16 fman Status feedback => assigned
2007-12-19 21:16 fman Assigned To => fman
2007-12-20 04:38 mhavlat Note Added: 0002848
2008-02-25 19:58 fman Status assigned => resolved
2008-02-25 19:58 fman Fixed in Version => next development version (1.8 Beta1)
2008-02-25 19:58 fman Resolution open => fixed
2008-06-03 16:48 mhavlat Fixed in Version next development version (1.8 Beta1) => 1.8 Beta 1
2008-11-07 19:47 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker