Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001045TestLinkNew Featurepublic2007-09-14 16:442008-11-07 19:46
Reporterjoemschi 
Assigned Tomhavlat 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 RC 3 
Fixed in Version1.8 Beta 1 
Summary0001045: Print Test Case with Requirements and Keywords
DescriptionAssigned requirements and keywords are not part of the printing options for test cases. This is in our opinion a major feature for reporting.

Attached you find the updated code of 4 files to include these options. Please verify, if you can include this extension in the normal release builds.

Source code changes are marked with: //JMU
ToDo: Localization, currently the strings are hard coded in german.
Attachment includes 4 source files and screenshot.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon TESTLINK_PATCH_JMU.zip [^] (204,347 bytes) 2007-09-14 16:44

- Relationships

-  Notes
(0002221)
mhavlat (reporter)
2007-09-24 05:22

Thanks. I'll look at it. It make sense.
(0002226)
joemschi (reporter)
2007-09-24 15:59

The attached code currently prints the field 'id' and 'title' for assigned requirements.

It should be enhanced to print 'req_doc_id' and 'title'. This field can be included in getReq4Tc. But I don't know about possible side effects.
(0002809)
mhavlat (reporter)
2007-12-11 07:06

I added the contribution to HEAD. Fixed localization and changes because of development.

- Issue History
Date Modified Username Field Change
2007-09-14 16:44 joemschi New Issue
2007-09-14 16:44 joemschi File Added: TESTLINK_PATCH_JMU.zip
2007-09-14 16:44 joemschi Browser => IE7
2007-09-24 05:22 mhavlat Note Added: 0002221
2007-09-24 05:22 mhavlat Assigned To => mhavlat
2007-09-24 05:22 mhavlat Status new => confirmed
2007-09-24 15:59 joemschi Note Added: 0002226
2007-11-12 07:53 mhavlat Status confirmed => assigned
2007-12-11 07:06 mhavlat Status assigned => resolved
2007-12-11 07:06 mhavlat Fixed in Version => next development version (1.8 Beta1)
2007-12-11 07:06 mhavlat Resolution open => fixed
2007-12-11 07:06 mhavlat Note Added: 0002809
2008-06-03 16:49 mhavlat Fixed in Version next development version (1.8 Beta1) => 1.8 Beta 1
2008-11-07 19:46 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker