Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001017TestLinkIntegration with Other Systemspublic2007-09-01 01:412008-12-08 20:03
Reportertoshi 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 RC 3 
Fixed in Version1.8 RC 1 
Summary0001017: garbled characters in Bugzilla integration
DescriptionWhen I integrate TestLink and Bugzilla,
multi-byte titles' characters of any bugs get garbled.

I think that the file "lib/bugtracking/int_bugtracking.php" need be modified.

------------------------------
- if (!$result['status'])
- $this->m_dbConnection = null;
-
---
+ if (!$result['status'])
+ {
+ $this->m_dbConnection = null;
+ }else{
+ if(BUG_TRACK_DB_TYPE == 'mysql')
+ {
+ $r = $this->m_dbConnection->exec_query("SET CHARACTER SET utf8");
+ $r = $this->m_dbConnection->exec_query("SET collation_connection = 'utf8_general_ci'");
+ }
+ }
------------------------------

Please investigate this issue.

Thanks.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0002018)
toshi (reporter)
2007-09-01 09:55

I open this issue instead of Mr. Yoshimura. He is a member of Japanese translation group.
(0002022)
fman (administrator)
2007-09-01 14:48

OK. We need to check the effects on not multibyte languages
(0002091)
mhavlat (reporter)
2007-09-10 22:02

You cannot modify a character set during a connection function. This is user responsibility to install both product with the same charset.

We cannot implement it anyway because we still support backward charset (not unicode) compatibility.

I suggest to reject.
(0002094)
toshi (reporter)
2007-09-10 22:57

Is the character-code of Bugzilla referenced anywhere?

Thanks.
(0002096)
toshi (reporter)
2007-09-11 08:36

As a quick fix, could we add the constant corresponding to character-set of Bugzilla?
For instance, I think following codes.

[in 'int_bugtracking.php']
--------------------------------------------------
+ define('BUG_TRACK_DB_CHARSET',"windows-1250");
+ // define('BUG_TRACK_DB_CHARSET',"gb2312");
+ // define('BUG_TRACK_DB_CHARSET',"UTF-8");
--------------------------------------------------

--------------------------------------------------
- if (!$result['status'])
- $this->m_dbConnection = null;
-
---
+ if (!$result['status'])
+ {
+ $this->m_dbConnection = null;
+ }else{
+ if(BUG_TRACK_DB_CHARSET == 'UTF-8' && BUG_TRACK_DB_TYPE == 'mysql')
+ {
+ $r = $this->m_dbConnection->exec_query("SET CHARACTER SET utf8");
+ $r = $this->m_dbConnection->exec_query("SET collation_connection = 'utf8_general_ci'");
+ }
+ }
--------------------------------------------------


These codes support backward compatibility for not unicode charset and upward compatibility for unicode charset.
(0002800)
mhavlat (reporter)
2007-12-07 05:52

Reminder sent to: fman

Francisco, do you think, that the suggested fix-workaround could be added into code?
(0002802)
ganlixiong (reporter)
2007-12-07 11:13

Thanks toshi,I use your "quick fix" method,and i fixed "garbled characters in Bugzilla integration " now! ^_^

thanks everyone work for testlink and SF!!!
(0004213)
schlundus (reporter)
2008-09-30 02:58

Charset can be defined like

define('BUG_TRACK_DB_CHARSET', 'ISO-8859-1');


with the cfg file of the corresponding bugtracking system

If not defined the charset of TestLink is used

- Issue History
Date Modified Username Field Change
2007-09-01 01:41 toshi New Issue
2007-09-01 09:55 toshi Note Added: 0002018
2007-09-01 14:48 fman Note Added: 0002022
2007-09-10 22:02 mhavlat Note Added: 0002091
2007-09-10 22:57 toshi Note Added: 0002094
2007-09-11 08:36 toshi Note Added: 0002096
2007-12-07 05:52 mhavlat Note Added: 0002800
2007-12-07 11:13 ganlixiong Note Added: 0002802
2007-12-07 19:15 fman Status new => assigned
2007-12-07 19:15 fman Assigned To => fman
2008-09-30 02:58 schlundus Status assigned => resolved
2008-09-30 02:58 schlundus Fixed in Version => next development 1.8 RC 1
2008-09-30 02:58 schlundus Resolution open => fixed
2008-09-30 02:58 schlundus Note Added: 0004213
2008-12-08 20:03 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker