Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001009TestLinkUsers and Rightspublic2007-08-29 21:552010-05-01 20:35
Reportermike_h 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 RC 3 
Fixed in Version1.9 Beta 2 
Summary0001009: After assigning testproject-role "admin" to user it cannot assign testproject-roles to other users
DescriptionCurrently everybody of our group, who is using TestLink, has the global role "guest" to see all testprojects currently entered (except of one user "admin", who has all rights). To set a maintainer for a testproject we created a role "ProjectMaintainer", which has among other rights the rights "Role assignment" (at "User" and "Test Plan"). This role is assigned to a user in a specific testproject. When this user logs in, the link "Assign user roles" at "Testproject Management" is not visible for it. (It is the same when assigning the testproject-role "admin" to the user).

I don't know if it was intended to give some users this kind of right but it would be nice if a user as projectmaintainer with this rights could change the roles of other users in this testproject (but not in others).
Additional InformationTo reproduce:
- Log in as user with global admin rights
- Create User "Testuser"
- Create Testproject "Testproject"
- Create Testplan "Testplan" for testproject "Testproject"
- Assign testproject-role "admin" to user "Testuser" for testproject "Testproject"
- Log out
- Log in as "Testuser"
- Link "Assign user roles" at the main screen is not visible
(It would be nice if this user as projectmaintainer can then allow other users to test, create testcases, ... in this specific testproject).
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 2.0.0.6
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
has duplicate 0002417closedfman Project admin should be able to assign users to own project 

-  Notes
(0001999)
jbarchibald
2007-08-30 02:09

I think there should be a discussion if this should be made to the codebase. I agree with the way it is currently deployed, however, to get the functionality your looking for,
go to roles.inc.php, and about line 80, remove the "user_role_assignment" element from the $g_rights_users_global array.

this way when you give someone admin rights to a project, the role assignment link will appear. or if you assign them any role that has "user_role_assignment" defined, they will see this link.

but be careful.. they will be able to edit role assignments for ANY project they have rights to, not just the project you have given them admin rights to.
(0002000)
mike_h (reporter)
2007-08-30 15:00

Thanks for your help! I edited the roles.inc.php and now it shows the link. Is there a easy way to filter the testprojects shown in the dropdown menue of the "Assign Test Project roles" screen to see (and edit) only the projects the user has rights to assign testproject roles to?
(0002621)
fman (administrator)
2007-11-09 02:07

Can we consider this issue resolved ?
(0002817)
mike_h (reporter)
2007-12-13 22:49

Sorry for the very late answer. I was working in a company during my holiday until end of august and therefore I have currently no system to test it. I will try to set up a PHP-MySQL Server on my own and test it there asap.
(0004537)
mhavlat (reporter)
2008-11-07 18:04

Guys, is there any progress? Could be closed?
(0005009)
shaisri (reporter)
2009-01-15 07:22

We are having the same issue with the implementation. As a global admin, I create "user1" as "inherited tester" with "admin" rights to testproject1.

When "user1" logs it, and selects testproject1, it would be most useful if he can see the "Assign user roles" (since he is admin for the project). However by commenting out the "user_role_assignment" element from the $g_rights_users_global array", we are giving user1 rights to change user roles for all projects where he is just a "tester"

Can it be fixed as "user1" having rights to "assign user roles" only for projects where he is admin (that would be a project he owns and administers) but does not have these rights for projects where he is using his inherited role of a "tester"

- Issue History
Date Modified Username Field Change
2007-08-29 21:55 mike_h New Issue
2007-08-29 21:55 mike_h Browser => Firefox 2.0.0.6
2007-08-30 02:09 jbarchibald Note Added: 0001999
2007-08-30 15:00 mike_h Note Added: 0002000
2007-11-09 02:07 fman Note Added: 0002621
2007-11-09 02:07 fman Status new => feedback
2007-12-13 22:49 mike_h Note Added: 0002817
2008-11-07 18:04 mhavlat Note Added: 0004537
2009-01-15 07:22 shaisri Note Added: 0005009
2009-04-27 14:44 fman Relationship added has duplicate 0002417
2009-04-27 14:44 fman Status feedback => assigned
2009-04-27 14:44 fman Assigned To => fman
2009-05-02 22:27 fman Status assigned => resolved
2009-05-02 22:27 fman Fixed in Version => 1.9 (DEV)
2009-05-02 22:27 fman Resolution open => fixed
2010-05-01 20:35 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker