Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001008TestLinkTest Executepublic2007-08-29 21:002008-11-07 19:47
Reporterpremraj 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 RC 2 
Fixed in Version1.8 Beta 2 
Summary0001008: Browser hangs when choosing to execute test case and next test case id is non-existant
DescriptionWhen a test case (eg. test case id=5494)is choosen to be executed after another test case is executed, the browser hangs with the 2 messages lines below:

Notice: Undefined offset: 5494 in /opt/lampp/htdocs/testlink/lib/execute/execSetResults.php on line 125

Notice: Undefined offset: 5494 in /opt/lampp/htdocs/testlink/lib/execute/execSetResults.php on line 127


This is not always reproducible.
We have a lot of test cases in the database. Also it is noticed that the next test case id is not available when this happens (eg. in the above test case id 5495 is missing or not available)

From the server it is noticed that the execSetResults is returning a huge amount of data (probably data from the first test case onwards)
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox and IE
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0001993)
fman (administrator)
2007-08-29 21:58

Update to last CVS tarball and retest
(0001995)
premraj (reporter)
2007-08-29 22:20

A correction: I confirmed that it has nothing to do with missing or non-available test cases. This is happening when a test case execution status is changed (test is executed) and then we go back and click on it once more.
For this to happen - we have to first choose "Not Run" test cases first.
(0002006)
fman (administrator)
2007-08-30 20:30
edited on: 2007-08-30 20:31

1. please give us an step by step example
2. do your tests only on LAST CVS TARBALL

(0002093)
mhavlat (reporter)
2007-09-10 22:19

I'm not able to reproduce with RC3. Do you mean use "Back" as firefox/ie function to move to one page back.
(0002097)
premraj (reporter)
2007-09-11 10:32

Steps to reproduce:

1. Login to Testlink, choose a TestPlan and Click Execute
2. In the 'Navigation Filter & Settings' choose a build
3. Choose "Not Run" test cases under Result
4. Click on a particular test case example: TC 1000
5. Choose a Results (Passed or Failed or Blocked) and "Save Execution"
6. Click on another test case example: TC 1002
7. Now click on the previous test case TC 1000
  At this point the display shows all the test cases and can hang the browser.
(0003161)
pepe (reporter)
2008-01-31 17:50

I still have the same problem, do you have any idea how to solve this???.
PD I'm woriking with the newest version of testlink.
(0003166)
fman (administrator)
2008-02-01 16:54

Please try updating tree after assigning status, and let us know.

Tree Auto refresh when you have a lot of test cases can be a problem
(0003188)
Marc Arens (reporter)
2008-02-05 16:34

We still have exactly the same problem as described by premraj on 09-11-07 03:32

Testlink Version:
TestLink 1.7.3

Error:
Notice: Undefined offset: 377 in /htdocs/testlink/lib/execute/execSetResults.php on line 143
Notice: Undefined offset: 377 in /htdocs/testlink/lib/execute/execSetResults.php on line 145

Is a manual reload of the tree still the only suggestion? This is just a rather ugly workaround for this bug.

We have set g_spec_cfg->automatic_tree_refresh=1 but does this even affect the tree when executing testcases?
(0003190)
fman (administrator)
2008-02-05 17:01

We can add a new refresh parameter , becuase refreshing when you have a lot of test is conumimg time operation.
Also depending tree manager, you can see your tree close => loose actual position

- Issue History
Date Modified Username Field Change
2007-08-29 21:00 premraj New Issue
2007-08-29 21:00 premraj Browser => Firefox and IE
2007-08-29 21:58 fman Note Added: 0001993
2007-08-29 22:20 premraj Note Added: 0001995
2007-08-30 20:30 fman Note Added: 0002006
2007-08-30 20:31 fman Note Edited: 0002006
2007-09-10 22:19 mhavlat Note Added: 0002093
2007-09-10 22:19 mhavlat Status new => feedback
2007-09-11 10:32 premraj Note Added: 0002097
2008-01-31 17:50 pepe Note Added: 0003161
2008-02-01 16:54 fman Note Added: 0003166
2008-02-05 16:34 Marc Arens Note Added: 0003188
2008-02-05 17:01 fman Note Added: 0003190
2008-02-05 17:02 fman Status feedback => assigned
2008-02-05 17:02 fman Assigned To => fman
2008-05-24 20:29 fman Status assigned => resolved
2008-05-24 20:29 fman Fixed in Version => 1.8 Beta 2
2008-05-24 20:29 fman Resolution open => fixed
2008-11-07 19:47 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker