MantisBT - TestLink
View Issue Details
0008759TestLinkBug Tracking System - JIRA Integrationpublic2019-09-09 04:022019-09-17 08:04
brahmam_klce 
fman 
highmajoralways
feedbackopen 
ubuntu18.04 64 bit18.04 64 bit
1.9.19 (2019 Q1) 
 
Mysql
chrome
PHP 7.2.19-0ubuntu0.18.04.2
0008759: After adding Jira bug tracking system successfully , not able to access JIRA bug ID link
Hi

Integrated JIRA from testlink using REST API. I was able to add the existing jira ID in to testlink test cases.

--> but after adding bug ID hyper link is not working.
--> Not able to create jira ticket , Version filed empty , if i fill also it was showing invalid.
--> Integrate JIRA BTS in to testlink 1.9.19 with below xml details

<issuetracker>
<username>jagadeesh</username>
<password>jaga123</password>
<uribase>192.168.1.115:8085/</uribase> [^]
<uriwsdl>192.168.1.115:8085/rpc/soap/jirasoapservice-v2?wsdl</uriwsdl> [^]
<uriview>192.168.1.115:8085/browse/</uriview> [^]
<uricreate>192.168.1.115:8085/secure/CreateIssue!default.jspa</uricreate> [^]
<projectkey>TES</projectkey>
<userinteraction>1</userinteraction>
<issuetype>TES-1</issuetype>
<issuepriority>1</issuepriority>
<attributes>
<versions>1</versions>
</attributes>
</issuetracker>

--> After adding successfully assign BTS to any project (bug ID : TES-8)

--> Fail the test cases & attach existing bug ID.

--> once added successfully try to access link

--> not able to access link.
No tags attached.
png Screenshot_2019-09-09 404 Not Found.png (10,988) 2019-09-09 04:27
http://mantis.testlink.org/file_download.php?file_id=5214&type=bug
png
Issue History
2019-09-09 04:02brahmam_klceNew Issue
2019-09-09 04:22brahmam_klceNote Added: 0029141
2019-09-09 04:27brahmam_klceFile Added: Screenshot_2019-09-09 404 Not Found.png
2019-09-10 08:54brahmam_klceNote Added: 0029142
2019-09-10 12:30fmanNote Added: 0029143
2019-09-10 12:32fmanAssigned To => fman
2019-09-10 12:32fmanStatusnew => feedback
2019-09-17 08:04testeravNote Added: 0029162

Notes
(0029141)
brahmam_klce   
2019-09-09 04:22   
if try to access from firefox browser i am getting error like :

"Not Found

The requested URL was not found on this server."

http://192.168.1.243:81/testlink/192.168.1.115:8085/browse/TES-8 [^]


actually my test link in "192.168.1.243"

Jira in "192.168.1.115"

its adding testlink URL before jira link , thats why not able to acces
(0029142)
brahmam_klce   
2019-09-10 08:54   
able to solve the issue...thx
(0029143)
fman   
2019-09-10 12:30   
ok, would you mind to provide details about how did you solve it?

regards
(0029162)
testerav   
2019-09-17 08:04   
I guess the problem was the url without the "https://". [^] I had this issue on the use of another program.

<uribase>https://192.168.1.115:8085/</uribase> [^] [^]
<uriwsdl>https://192.168.1.115:8085/rpc/soap/jirasoapservice-v2?wsdl</uriwsdl> [^] [^]
<uriview>https://192.168.1.115:8085/browse/</uriview> [^] [^]
<uricreate>https://192.168.1.115:8085/secure/CreateIssue!default.jspa</uricreate> [^] [^]