MantisBT - TestLink
View Issue Details
0008595TestLinkReq Overviewpublic2019-03-12 18:302019-03-12 22:38
hguilherme66 
fman 
highminoralways
resolvedfixed 
1.9.19 (2019 Q1) 
 
MariaDB 10.3.12
Chrome
5.5.38
TBD
0008595: SQL error when accessing Requirements Overview
A DB Access Error appeared when I accessed Requirements Overview in a project having Requirements Specifications defined.
Clicked Requirements Overview in a project having Requirements Specifications (and also executed Tests with coverage), and the following error appears:
 ==============================================================================
 DB Access Error - debug_print_backtrace() OUTPUT START
 ATTENTION: Enabling more debug info will produce path disclosure weakness (CWE-200)
            Having this additional Information could be useful for reporting
            issue to development TEAM.
 ==============================================================================
#0 database->exec_query(/* Class:requirement_mgr - Method: getLatestReqVersionCoverageCounterSet */ SELECT RCOV.req_id, COUNT(0) AS qty FROM req_coverage RCOV JOIN latest_req_version_id LRQV ON LRQV.req_version_id = RCOV.req_version_id WHERE LRQV.req_version_id IN (5747,5749) AND is_active = 1 GROUP BY RCOV.req_id , -1) called at [(removed)/testlink/lib/functions/database.class.php:637]
#1 database->fetchRowsIntoMap(/* Class:requirement_mgr - Method: getLatestReqVersionCoverageCounterSet */ SELECT RCOV.req_id, COUNT(0) AS qty FROM req_coverage RCOV JOIN latest_req_version_id LRQV ON LRQV.req_version_id = RCOV.req_version_id WHERE LRQV.req_version_id IN (5747,5749) AND is_active = 1 GROUP BY RCOV.req_id , req_id) called at [(removed)/testlink/lib/functions/requirement_mgr.class.php:4775]
0000002 requirement_mgr->getLatestReqVersionCoverageCounterSet(Array ([0] => 5747,[1] => 5749)) called at [/var/www/qa/public_html/testlink/lib/requirements/reqOverview.php:77]
This was a first time installation of TL.

During Installation there was no report of failure to create the Views (or I did not notice any).

There was no Views created in DB.
I successful created the missing Views by running that part of the SQL script.

The problem became solved.
No tags attached.
Issue History
2019-03-12 18:30hguilherme66New Issue
2019-03-12 18:34hguilherme66Note Added: 0028587
2019-03-12 22:36fmanNote Added: 0028589
2019-03-12 22:36fmanQA Team - Task Workflow Status => TBD
2019-03-12 22:36fmanNote Added: 0028590
2019-03-12 22:36fmanStatusnew => resolved
2019-03-12 22:36fmanResolutionopen => fixed
2019-03-12 22:36fmanAssigned To => fman
2019-03-12 22:38fmanNote Edited: 0028590bug_revision_view_page.php?bugnote_id=28590#r5766

Notes
(0028587)
hguilherme66   
2019-03-12 18:34   
This is related with 0008480
(0028589)
fman   
2019-03-12 22:36   
Just tested using branch 1.9.19.01 on OSX, using MAMP Pro, no issues
(0028590)
fman   
2019-03-12 22:36   
(edited on: 2019-03-12 22:38)
unable to reproduce on 1.9.19.01, when NO TABLE PREFIX is used