MantisBT - TestLink
View Issue Details
0007124TestLinkFilters - Test Specificationpublic2015-05-19 18:442016-09-03 16:48
sbill 
fman 
normalminoralways
feedbackopen 
1.9.13Windows7
1.9.13 (2015 #1) 
 
MySQL
Firefox
TBD
0007124: Filter function returns nothing with a list custom field with a single value
Applying the filter function in the test spec returns an empty list when nothing is selected, when there is a custom field of type "list" and containing exactly one value.

I tried this on version 1.9.12 and the error does not occur.
1. create a custom field with name "single". For possible values, enter "one"
2. Assign the custom field to the project
2. create a test case: "tc1". No special values
3. Go to the test spec. Observe that the number of items in the tree is greater than zero
4. Select the "Apply" button in the filter section of the navigator. The result will be an empty list.
5. Unassign the "single" custom field and the error does not occur
No tags attached.
xml customFields.xml (1,597) 2015-05-20 18:49
http://mantis.testlink.org/file_download.php?file_id=4208&type=bug
xml test_testproject-deep.xml (802) 2015-05-20 18:50
http://mantis.testlink.org/file_download.php?file_id=4209&type=bug
Issue History
2015-05-19 18:44sbillNew Issue
2015-05-20 13:15sbillNote Added: 0023378
2015-05-20 18:20fmanNote Added: 0023380
2015-05-20 18:20fmanAssigned To => fman
2015-05-20 18:20fmanStatusnew => feedback
2015-05-20 18:49sbillFile Added: customFields.xml
2015-05-20 18:50sbillFile Added: test_testproject-deep.xml
2016-09-03 16:48fmanQA Team - Task Workflow Status => TBD

Notes
(0023378)
sbill   
2015-05-20 13:15   
Note that the same behaviour also occurs when you have list with multiple items and one of the items is empty. For example where the list values are: "one|two||four".
(0023380)
fman   
2015-05-20 18:20   
Please provide Custom Fields in standard testlink XML file, in order to allow me to work with same definition.

Please provide Test Spec XML export file, in order to allow me to work with same scenario