MantisBT - TestLink
View Issue Details
0006742TestLinkTest Plan Managementpublic2014-11-12 03:282014-12-31 14:22
imraneo 
fman 
highminoralways
closedfixed 
XAMPPWindows7
1.9.12 (2014 Q3) 
1.9.13 (2015 #1) 
MySQL
Any
5.16.1
READY FOR TESTING
0006742: Creating/editing test plan throws you to a fatal error page
Upon creating/editing a testplan, it throws me to a page with the following error:

Fatal error: Call to a member function hasRight() on a non-object in E:\xampp\htdocs\testlink2\lib\plan\planEdit.php on line 281

As description
All users are Admin. My database was migrated from v1.9.4 to v1.9.12 using multiple SQL scripts according to documentation.

I have a total of 48 users and somehow the new users (from ID 30 onwards) do NOT see this problem. The older users (prior to ID 30) see this problem.
Newly created users in v1.9.12 are alright as well.

Despite this error, the adding/editing testplan does go through.
No tags attached.
Issue History
2014-11-12 03:28imraneoNew Issue
2014-11-12 11:16fmanNote Added: 0022117
2014-11-12 11:16fmanAssigned To => fman
2014-11-12 11:16fmanStatusnew => feedback
2014-11-13 05:46imraneoNote Added: 0022127
2014-11-13 05:46imraneoStatusfeedback => assigned
2014-11-13 09:58fmanQA Team - Task Workflow Status => READY FOR TESTING
2014-11-13 09:58fmanFixed in Version => 1.9.13 (2015 #1)
2014-11-13 09:58fmanStatusassigned => resolved
2014-11-13 09:58fmanResolutionopen => fixed
2014-12-31 14:22fmanStatusresolved => closed

Notes
(0022117)
fman   
2014-11-12 11:16   
1. searching for similar issues is a MUST BEFORE REPORTING
2. applying available fixes also

have you searched for similar issues before reporting ?
get latest code from gitorious (branch 1.9), do fresh install on sandbox , retest and provide feedback
(0022127)
imraneo   
2014-11-13 05:46   
1. The closest issue I found was 6620 but created a new ticket as the error/observations were somewhat different.

2. Applied the fix shown in 6620 but didn't work.

Updated my planView.php and planEdit.php from the gitorious branch 1.9 and problem was solved.
Thanks for the advice. You may close this ticket.