MantisBT - TestLink
View Issue Details
0006210TestLinkBug Tracking System - Redmine Integrationpublic2014-02-17 08:472014-04-25 17:38
kwojciechowska 
fman 
normalminoralways
closedfixed 
ALL
1.9.9 (2013 Q4 - bug fixing) 
1.9.10 (2014 Q1 - bug fixing) 
MySQL 5.0.3
ALL
5.4
READY FOR TESTING
0006210: Bug creation via API (redmine connection) is not working
I've installed Testlink 1.9.9 and it's integrated with Redmine through API key.
After clicking on 'Create issue' button, a blank page opens(in chrome, in IE there is a HTTP 500 error).
Assosiating existing error (button: 'Link Existent issue') with Redmine works fine.

My configuration is:
<issuetracker>
<apikey>xxx</apikey>
<uribase>http://xxx/</uribase> [^] [^]
<uriview>http://xxx/issues/</uriview> [^] [^]
<projectidentifier>project_id_in_redmine</projectidentifier>
</issuetracker>
Create a connection between Testlink and Redmine.
Execute test case.
Try to report a bug through Testlink interface - click on 'Create issue' button - blank page appeared and nothing happened.
No tags attached.
child of 0006048closed fman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 
jpg create_issue_error (1).jpg (284,521) 2014-02-17 08:47
http://mantis.testlink.org/file_download.php?file_id=3616&type=bug
Issue History
2014-02-17 08:47kwojciechowskaNew Issue
2014-02-17 08:47kwojciechowskaFile Added: create_issue_error (1).jpg
2014-02-17 08:53kwojciechowskaNote Added: 0020453
2014-02-17 08:58fmanNote Added: 0020454
2014-02-17 09:03fmanQA Team - Task Workflow Status => TBD
2014-02-17 09:03fmanSummaryBug creation (redmine connection) is not working from testlink => Bug creation via API (redmine connection) is not working
2014-02-17 10:15fmanNote Added: 0020456
2014-02-17 10:16fmanAssigned To => fman
2014-02-17 10:16fmanStatusnew => feedback
2014-02-17 10:44fmanNote Added: 0020459
2014-02-17 11:06fmanNote Added: 0020460
2014-02-17 11:06fmanQA Team - Task Workflow StatusTBD => READY FOR TESTING
2014-02-17 11:06fmanStatusfeedback => resolved
2014-02-17 11:06fmanFixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2014-02-17 11:06fmanResolutionopen => fixed
2014-02-17 11:06fmanRelationship addedchild of 0006048
2014-04-25 17:38fmanNote Added: 0020831
2014-04-25 17:38fmanStatusresolved => closed

Notes
(0020453)
kwojciechowska   
2014-02-17 08:53   
In version 1.9.8 of Testlink creating issues from TL worked fine.
(0020454)
fman   
2014-02-17 08:58   
1. create a test instance of testlink using latest code from gitoriuos and retest
2. give a look to TestLink logs in order to check if more specific error message appears
(0020456)
fman   
2014-02-17 10:15   
1. install redmine using bitnami installer (linux 32 bits) on fedora 20
2. create just user admin on redmine
3. create a project
4. enable rest api
5. install testlink on same machine but running on other webserver on port
6. test issue creation using sample php provided on TL INSTALLATION under
issuetrackeintegration\code_testing\redmine\

7. issue created without problems

I suggest do same kind of test, while I'm going to try to check with integration from testlink GUI.

Tested with latest code from gitorious
(0020459)
fman   
2014-02-17 10:44   
When trying to create issue from execution feature got:

Create REDMINE Ticket FAILURE => redmine::_requesturl:http://127.0.0.1:8085/redmine [^] - response:Array - content: - serialized issue:N;


More investigation is needed.
(0020460)
fman   
2014-02-17 11:06   
My issue was related to a BAD API KEY, I've got HTTP 401 Unauthorized

Tested with latest code from gitorious
(0020831)
fman   
2014-04-25 17:38   
1.9.10 released