MantisBT - TestLink
View Issue Details
0006086TestLinkTest Execute - 'Save and move to next'public2013-12-09 16:572013-12-13 19:43
ntr 
fman 
normalminoralways
closedfixed 
1.9.9 (2013 Q4 - bug fixing) 
1.9.10 (2014 Q1 - bug fixing) 
MySql
Firefox
READY FOR TESTING
0006086: "Save an move to next" doesn't work
Maybe I do not understand the functionnality, but when I click on "save and move to next" during test execution, testlink:
- saves the current test (OK)
- jump to 'test execution main page' (why not)
- does nothing more => I would expect testlink to open the next testcase in the execution sequence.

Maybe I did not configure something fine, maybe I do not understand how it works, or maybe there is an issue ?

Could you explain me ?
1. create test project TPRJ
2. create a test suite TS100
3. create a test case TC-1A
4. create a test case TC-1B
5. create a test case TC-1C
6. create a test case TC-1D
7. Add tests to a campaign
8. Go to main screen (desktop)
9. On right menu, go to Execute tests
10. On left menu, select first test in testsuite TS100
11. On right pane, go down and set a result
12. Click on save and move to next
No tags attached.
Issue History
2013-12-09 16:57ntrNew Issue
2013-12-09 20:23fmanNote Added: 0020177
2013-12-09 20:23fmanAssigned To => fman
2013-12-09 20:23fmanStatusnew => assigned
2013-12-09 20:23fmanQA Team - Task Workflow StatusTBD => READY FOR TESTING
2013-12-09 20:23fmanFixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2013-12-10 10:44ntrNote Added: 0020182
2013-12-10 11:36fmanNote Added: 0020183
2013-12-10 11:36fmanStatusassigned => resolved
2013-12-10 11:36fmanResolutionopen => fixed
2013-12-13 17:23twelveNote Added: 0020206
2013-12-13 19:43fmanStatusresolved => closed

Notes
(0020177)
fman   
2013-12-09 20:23   
issue fixed on latest code from gitorious
(0020182)
ntr   
2013-12-10 10:44   
I've tried to look to the repository to get your modification for this point.
Unfortunately, I'm not able to track any modification done to solve this issue.
(0020183)
fman   
2013-12-10 11:36   
Idea is not that you are going to find the exact change, but that latest code works and this is a fact.
closing
(0020206)
twelve   
2013-12-13 17:23   
@ntr
To answer your question: You have to delete the script "parent.workframe.location='{$gui->src_workframe}';" inside of gui/templates/execute/execNavigator.tpl