MantisBT - TestLink
View Issue Details
0005410TestLinkReportspublic2012-12-09 09:572013-05-26 18:52
fman 
fman 
normalminorhave not tried
closedfixed 
1.9.5 (2012 Q4 - bug fixing) 
1.9.6 (2013 Q1 - bug fixing) 
Postgres
READY FOR TESTING
0005410: Test Cases without Tester Assignment - Crash
Login as admin
There is one test project (PUBLIC ACCESS) with 2 test plans
go to reports
click on Test Cases without Tester Assignment

got
=============================================================
 ==============================================================================

 DB Access Error - debug_print_backtrace() OUTPUT START

 ==============================================================================

#0 database->exec_query() called at [/hdextra/development/gitrepo/tlcode/lib/functions/database.class.php:743]
#1 database->get_recordset() called at [/hdextra/development/gitrepo/tlcode/lib/functions/tlTestPlanMetrics.class.php:2212]
0000002 tlTestPlanMetrics->getNotRunWOTesterAssigned() called at [/hdextra/development/gitrepo/tlcode/lib/results/testCasesWithoutTester.php:53]

 ==============================================================================
TO BE FIXED on 2.0
child of 0005406closed fman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 
child of 0005193closed fman Availables hot-fixes for 1.9.4 & How To get full fixed package from gitorious 
Issue History
2012-12-09 09:57fmanNew Issue
2012-12-09 09:57fmanStatusnew => assigned
2012-12-09 09:57fmanAssigned To => fman
2012-12-09 16:32fmanNote Added: 0018004
2012-12-09 16:52fmanTag Attached: TO BE FIXED on 2.0
2012-12-09 16:52fmanTask Workflow StatusTBD => READY FOR TESTING
2012-12-09 16:52fmanStatusassigned => resolved
2012-12-09 16:52fmanFixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2012-12-09 16:52fmanResolutionopen => fixed
2012-12-09 16:52fmanRelationship addedchild of 0005406
2012-12-09 16:53fmanRelationship addedchild of 0005193
2013-05-26 18:52fmanStatusresolved => closed

Notes
(0018004)
fman   
2012-12-09 16:32   
Issue due to using ALIAS ON HAVING CLAUSE
http://stackoverflow.com/questions/7511064/postresql-aliases-column-and-having [^]