MantisBT - TestLink
View Issue Details
0003951TestLinkRequirement Managementpublic2010-10-28 05:122010-11-14 12:07
KathrinMarkus 
asimon 
normalminoralways
closedfixed 
1.9 RC 1 
1.9 (Prague) 
-
Firefox 3.6.10, Internet Explorer 8
0003951: Status and Type for requirements are not saved
if I edit a requirement I can change the status and the type for a requirement. But this change will be never saved in the database (field is always empty).
edit an existing requirement
change the status and the type
save
check status and type => isn't set (NOK)
No tags attached.
Issue History
2010-10-28 05:12KathrinMarkusNew Issue
2010-10-28 07:25JulianSummaryStatus and Type for requirements are not saved => [MSSQL] Status and Type for requirements are not saved
2010-10-28 07:25JulianNote Added: 0012109
2010-10-28 09:17KathrinMarkusNote Added: 0012112
2010-10-28 09:29asimonNote Added: 0012113
2010-10-28 09:38asimonNote Added: 0012114
2010-10-28 09:40KathrinMarkusNote Added: 0012115
2010-10-28 09:56asimonNote Added: 0012116
2010-10-28 09:57asimonStatusnew => resolved
2010-10-28 09:57asimonFixed in Version => 1.9 (Prague)
2010-10-28 09:57asimonResolutionopen => fixed
2010-10-28 09:57asimonAssigned To => asimon
2010-10-28 09:57JulianStatusresolved => assigned
2010-10-28 09:57JulianResolutionfixed => reopened
2010-10-28 09:58JulianDatabaseMSSQL => -
2010-10-28 09:58JulianSummary[MSSQL] Status and Type for requirements are not saved => Status and Type for requirements are not saved
2010-10-28 09:58JulianStatusassigned => resolved
2010-10-28 09:58JulianResolutionreopened => fixed
2010-11-14 12:07fmanNote Added: 0012527
2010-11-14 12:07fmanStatusresolved => closed

Notes
(0012109)
Julian   
2010-10-28 07:25   
works with mysql -> mssql added to summary
(0012112)
KathrinMarkus   
2010-10-28 09:17   
sorry, I select the wrong database in the Issue. I use a MySQL database. Please change it.

I have also take a look into the logfile and it seems that the function iconv_substr isn't available (I don't know if this is the error)

iconv_substr() [<a href='function.iconv-substr'>function.iconv-substr</a>]: Unknown error (0) - in C:\EasyWAMP\www\testlink_1_9_RC1\lib\functions\common.php - Line 953
(0012113)
asimon   
2010-10-28 09:29   
This seems to be an error with your PHP version. Take a look at the comments there: http://de.php.net/manual/en/function.iconv-substr.php [^]
(0012114)
asimon   
2010-10-28 09:38   
iconv_substr() is used in common.php on line 1019. That's the only occurrence of the function. Seems like we can replace it by mb_substr().
I tried that and didn't notice any side effects.

KathrinMarkus, can you try if that works for you?
(0012115)
KathrinMarkus   
2010-10-28 09:40   
it works perfectly (thank you :-))
(0012116)
asimon   
2010-10-28 09:56   
Thanks for trying!
It's committed to our CVS now and will be in TL 1.9.
(0012527)
fman   
2010-11-14 12:07   
1.9 (Prague) Released