MantisBT - TestLink
View Issue Details
0002286TestLinkTest Executepublic2009-03-26 22:102010-01-14 19:18
syrius765 
mhavlat 
normalminorhave not tried
closedfixed 
1.7.4 
1.8.1 
firefox
5.2.0
0002286: Accented character "éè"
When we set a word with "é","è... (used a lot in french) the save truncate the text on these character.

exemple : "Le bug suivant a été relevé" will be "Le bug suivant a ".


Is it a problem of configuration ? I don't find an issue for this problem.

No tags attached.
duplicate of 0002250closed schlundus ICONV code page conversion even in case that source and target encoding are the same 
jpg note.jpg (110,070) 2009-03-31 18:18
http://mantis.testlink.org/file_download.php?file_id=912&type=bug
jpg

? config.inc.php (38,963) 2009-04-14 17:54
http://mantis.testlink.org/file_download.php?file_id=957&type=bug
jpg configSql.jpg (160,143) 2009-04-14 17:54
http://mantis.testlink.org/file_download.php?file_id=958&type=bug
jpg

htm info.php.htm (53,558) 2009-04-14 18:01
http://mantis.testlink.org/file_download.php?file_id=959&type=bug
Issue History
2009-03-26 22:10syrius765New Issue
2009-03-26 22:10syrius765Browser => firefox
2009-03-26 22:10syrius765PHP Version => 5.2.0
2009-03-26 23:14mhavlatRelationship addedduplicate of 0002250
2009-03-26 23:17mhavlatNote Added: 0006015
2009-03-26 23:17mhavlatAssigned To => mhavlat
2009-03-26 23:17mhavlatStatusnew => resolved
2009-03-26 23:17mhavlatFixed in Version => 1.8.1 (bug fixes)
2009-03-31 18:15syrius765Statusresolved => assigned
2009-03-31 18:15syrius765Resolutionopen => reopened
2009-03-31 18:15syrius765Note Added: 0006101
2009-03-31 18:16syrius765Note Edited: 0006101
2009-03-31 18:18syrius765File Added: note.jpg
2009-03-31 18:18syrius765Note Edited: 0006101
2009-03-31 18:24syrius765Note Added: 0006102
2009-03-31 18:55mhavlatNote Added: 0006104
2009-04-06 14:26mhavlatNote Added: 0006220
2009-04-08 19:24syrius765Note Added: 0006288
2009-04-10 04:11schlundusNote Added: 0006332
2009-04-10 11:34toshiNote Added: 0006333
2009-04-14 17:54syrius765File Added: config.inc.php
2009-04-14 17:54syrius765File Added: configSql.jpg
2009-04-14 18:01syrius765File Added: info.php.htm
2009-04-14 18:02syrius765Note Added: 0006363
2009-04-14 20:53toshiNote Added: 0006364
2009-04-24 17:46syrius765Note Added: 0006578
2009-04-24 20:59syrius765Note Added: 0006581
2010-01-14 19:18mhavlatNote Added: 0008686
2010-01-14 19:18mhavlatStatusassigned => closed
2010-01-14 19:18mhavlatResolutionreopened => fixed

Notes
(0006015)
mhavlat   
2009-03-26 23:17   
It looks like a duplicate of 2250. Let me know if not. Thanks.
(0006101)
syrius765   
2009-03-31 18:15   
(edited on: 2009-03-31 18:18)
migration to latest 1.8.0, the bug is still here

Try to add note : "test éé test '' test èè test", display note is "test"


see screenshot

(0006102)
syrius765   
2009-03-31 18:24   
I see in 2250 that the bug is resolved in 1.8.1, but i download the latest version on http://sourceforge.net/project/showfiles.php?group_id=90976&package_id=270236 [^]
and it seems that I have got the 1.8.0. where can i find the version 1.8.1 ?

Thanks
(0006104)
mhavlat   
2009-03-31 18:55   
not released yet. you can download the code from SVC or wait several days.
(0006220)
mhavlat   
2009-04-06 14:26   
So, TL 1.8.1 is available. Please, let me know, if the issue is solved. Thanks.
(0006288)
syrius765   
2009-04-08 19:24   
Update to 1.8.1

Notes are still truncated on caracters : é,è,à,
(0006332)
schlundus   
2009-04-10 04:11   
Hm, i'm not able to reproduce the problem
(0006333)
toshi   
2009-04-10 11:34   
> syrius765

Thank you for your reports.
Could we get your TestLink and PHP configuration file?
So I can try reproducing this issue.
(0006363)
syrius765   
2009-04-14 18:02   
Files in attachement.

If you don t reproduce the problem, it seems to be our php configuration files for the charset...
(0006364)
toshi   
2009-04-14 20:53   
Thanks.
I try reproducing with your files.
(0006578)
syrius765   
2009-04-24 17:46   
Is there a testlink of test where i can try to reproduce my bug on your config ?
(0006581)
syrius765   
2009-04-24 20:59   
Resolved : change utf-8 to $tlCfg->charset = 'ISO-8859-1'; in config.inc.php


So it was finally a problem between the chair and the keyboard.
(0008686)
mhavlat   
2010-01-14 19:18   
Thanks for report. Closed.